Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7381 closed bug (fixed)

GetVectorIcon - Bug for size bigger than 256

Reported by: cipri Owned by: stippi
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

It seems GetVectorIcon cannot load hvif icons into Bitmaps larger than 256x256. There are no error-message, just in my case the icon is not displayed if the bitmap was choosen to have a width langer than 256. If it's smaller than 256 everything works like expected. This bug can be also noticed, if in the file of global definitions of the app Pairs the constant of the icon-size is changed to 260 for example.

Change History (3)

comment:1 Changed 8 years ago by anevilyak

Owner: changed from axeld to stippi
Status: newassigned

The problem is that the level of detail rendering code isn't rendering any shapes at sizes > 256 because all shapes come back with a max visibility scale of 4, which sizes > 256 exceed (since the scale factor is based on bitmap width / 64).

comment:2 Changed 8 years ago by anevilyak

Resolution: fixed
Status: assignedclosed
Version: R1/alpha2R1/Development

Fixed in hrev41206.

comment:3 Changed 8 years ago by stippi

Please reopen if the problem is not actually fixed. I only stared hard at the line of code I've added and otherwise tested only that regular icon sizes still work. :-)

Note: See TracTickets for help on using tickets.