Opened 9 years ago

Closed 18 months ago

#7411 closed bug (fixed)

Applications needs to be restared after new IP from DHCP

Reported by: deejam Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/net_server Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

When a new IP address has been issued by a DHCP server, the running applications lose their network connectivity and needs to be restarted. Ping is not affected. WebPositive, wget, Visions etc are affected.

How to reproduce:

  • Connect to a DHCP server that issues a new IP on DHCP_RELEASE/DHCP_DISCOVER (DD-WRT v24-sp2 does that).
  • Launch WebPositive and load a web page.
  • Unplug network cable.
  • Plug network cable.
  • Check syslog and make sure that you got a different IP address.
  • Reload the web page in WebPositive (won't load).
  • Restart WebPositive. Load a web page (will load).

Expected behaviour:

WebPositive should be able to load web pages after a new IP address has been obtained without being restarted.

See #7380 for a description of the problem and log files.

See #7346 for the reason why a new DHCP address is obtained.

hrev40991 GCC2 Hybrid.

Attachments (1)

syslog (286.9 KB ) - added by Premislaus 7 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 by Premislaus, 7 years ago

I am another victim... At some point, Web+ stops loading websites.

Check syslog and make sure that you got a different IP address - I have static IP.

This is hrev45385 gcc2h.

by Premislaus, 7 years ago

Attachment: syslog added

comment:2 by waddlesplash, 18 months ago

Resolution: fixed
Status: newclosed

Works for me now.

Note: See TracTickets for help on using tickets.