Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7432 closed bug (fixed)

StyledEdit crashes when opening text files

Reported by: taos Owned by: nobody
Priority: normal Milestone: R1
Component: Applications/StyledEdit Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Using hrev41185 (gcc2hybrid).

When opening a text file via double click or by using the file menu StyledEdit crashes. Attached is the debugger information (Debug_StyledEdit_open.txt).

bt shows:

(gdb) bt
#0  0x00210fbc in StyledEditWindow::MessageReceived ()
#1  0x002efd1f in BLooper::DispatchMessage () from /boot/system/lib/libbe.so
#2  0x003bd15c in BWindow::DispatchMessage () from /boot/system/lib/libbe.so
#3  0x003c139c in BWindow::task_looper () from /boot/system/lib/libbe.so
#4  0x002f123b in BLooper::_task0_ () from /boot/system/lib/libbe.so
#5  0x0082a1d2 in thread_entry () from /boot/system/lib/libroot.so
#6  0x70080fec in ?? ()
(gdb)

I'm not really sure but I think StyledEdit still worked in hrev41168.

Attachments (1)

Debug_StyledEdit_open.txt (6.0 KB) - added by taos 8 years ago.

Download all attachments as: .zip

Change History (13)

Changed 8 years ago by taos

Attachment: Debug_StyledEdit_open.txt added

comment:1 Changed 8 years ago by axeld

Owner: changed from korli to stippi
Status: newassigned

There was a recent change that maybe is causing this, reassigning to stippi to have a look. And this happens with any text file?

comment:2 Changed 8 years ago by stippi

What recent change did I do that has to do with StyledEditWindow?

comment:3 Changed 8 years ago by axeld

I thought I had seen a change in the StyledText translator from you recently, but nevermind if that wasn't the cause :-)

comment:4 Changed 8 years ago by stippi

Such a change might be the cause but it isn't the case that I did such a change... :-) At least not that I remember.

comment:5 in reply to:  1 Changed 8 years ago by taos

Replying to axeld:

And this happens with any text file?

So far, I've seen this behaviour with text/plain, text/html, text/x-email, text/x-jamfile, text/x-source-code and text/x-patch. Might happen with any text file - has happend with every text file I've tried.

comment:6 in reply to:  4 Changed 8 years ago by axeld

Owner: changed from stippi to nobody

Replying to stippi:

Such a change might be the cause but it isn't the case that I did such a change... :-) At least not that I remember.

I even wanted to write "case", and only noticed afterwards that I wrote "cause" :-) In any case, you just made a change to the Icon-O-Matic StyledTextImporter which is entirely unlikely to have any effect on StyledEdit - that's what you get when only skimming over commits. Sorry for the noise.

comment:7 Changed 8 years ago by taos

The change you refer to, is it [41184] when the following lines were removed from StyledEditWindow.cpp?

    menu->AddItem(fClearItem = new BMenuItem(B_TRANSLATE("Clear"),
         new BMessage(MENU_CLEAR))); 
    fClearItem->SetEnabled(false);
    fClearItem->SetTarget(fTextView); 

comment:8 Changed 8 years ago by stippi

Good catch. I'll have a look. I was already suspecting some localization or cleanup commit with accidentally too much cleanup...

comment:9 Changed 8 years ago by stippi

Resolution: fixed
Status: assignedclosed

Should be fixed in hrev41187. Please reopen if not.

comment:10 Changed 8 years ago by axeld

Looks like it pays off to randomly assign you tickets ;-)

comment:11 Changed 8 years ago by taos

Great. Complained, code patched, compiled, tested, problem fixed. That was really fast:-) Thanks!

comment:12 Changed 8 years ago by humdinger

Sorry for having caused trouble. Obviously a thorough test would have included opening a file. I'll try to do better in the future.

Note: See TracTickets for help on using tickets.