Opened 8 years ago

Closed 8 years ago

#7477 closed bug (duplicate)

USB disk drives "flash thumbs and usb 2.0 HDDs" not recognized

Reported by: stargatefan Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/USB Version: R1/Development
Keywords: AMD USB Cc:
Blocked By: #5551 Blocking:
Has a Patch: no Platform: All

Description (last modified by mmlr)

Not really sure whats going on here. Tested with numerous nightlys. USB subsystem appears to work but thumb drives and external HDD's do not.

Here is the list dev. This was with the USB thumb drive and the USB joystick plugged into the same hub and into different hubs. this will block booting on other AMD chipsets.

Welcome to the Haiku shell.

~> listusb
046d:c05a /dev/bus/usb/0/4 "Logitech" "USB Optical Mouse" ver. 5400
0000:0000 /dev/bus/usb/0/hub "HAIKU Inc." "OHCI RootHub" ver. 0110
1bad:f016 /dev/bus/usb/1/3 "Mad Catz, Inc." "MadCatz GamePad" ver. 0490
0000:0000 /dev/bus/usb/1/hub "HAIKU Inc." "OHCI RootHub" ver. 0110
0000:0000 /dev/bus/usb/2/hub "HAIKU Inc." "OHCI RootHub" ver. 0110
0000:0000 /dev/bus/usb/3/hub "HAIKU Inc." "OHCI RootHub" ver. 0110
0000:0000 /dev/bus/usb/4/hub "HAIKU Inc." "EHCI RootHub" ver. 0200
0000:0000 /dev/bus/usb/5/hub "HAIKU Inc." "EHCI RootHub" ver. 0200
0000:0000 /dev/bus/usb/6/hub "HAIKU Inc." "EHCI RootHub" ver. 0200
~> listusb
046d:c05a /dev/bus/usb/0/4 "Logitech" "USB Optical Mouse" ver. 5400
0000:0000 /dev/bus/usb/0/hub "HAIKU Inc." "OHCI RootHub" ver. 0110
1bad:f016 /dev/bus/usb/1/3 "Mad Catz, Inc." "MadCatz GamePad" ver. 0490
0000:0000 /dev/bus/usb/1/hub "HAIKU Inc." "OHCI RootHub" ver. 0110
0000:0000 /dev/bus/usb/2/hub "HAIKU Inc." "OHCI RootHub" ver. 0110
0000:0000 /dev/bus/usb/3/hub "HAIKU Inc." "OHCI RootHub" ver. 0110
0000:0000 /dev/bus/usb/4/hub "HAIKU Inc." "EHCI RootHub" ver. 0200
0000:0000 /dev/bus/usb/5/hub "HAIKU Inc." "EHCI RootHub" ver. 0200
0000:0000 /dev/bus/usb/6/hub "HAIKU Inc." "EHCI RootHub" ver. 0200
~> listdev

device Bridge (Host bridge) [6|0|0]
  vendor 1022: Advanced Micro Devices [AMD]
  device 1204: Family 10h Processor Link Control

device Bridge (Host bridge) [6|0|0]
  vendor 1022: Advanced Micro Devices [AMD]
  device 1203: Family 10h Processor Miscellaneous Control

device Bridge (Host bridge) [6|0|0]
  vendor 1022: Advanced Micro Devices [AMD]
  device 1202: Family 10h Processor DRAM Controller

device Bridge (Host bridge) [6|0|0]
  vendor 1022: Advanced Micro Devices [AMD]
  device 1201: Family 10h Processor Address Map

device Bridge (Host bridge) [6|0|0]
  vendor 1022: Advanced Micro Devices [AMD]
  device 1200: Family 10h Processor HyperTransport Configuration

device Serial bus controller (USB Controller, EHCI) [c|3|20]
  vendor 1002: ATI Technologies Inc
  device 4396: SB700/SB800 USB EHCI Controller

device Serial bus controller (USB Controller, OHCI) [c|3|10]
  vendor 1002: ATI Technologies Inc
  device 4397: SB700/SB800 USB OHCI0 Controller

device Network controller (Ethernet controller) [2|0|0]
  vendor 10ec: Realtek Semiconductor Co., Ltd.
  device 8168: RTL8111/8168B PCI Express Gigabit Ethernet controller

device Bridge (PCI bridge, Normal decode) [6|4|0]
  vendor 1002: ATI Technologies Inc
  device 43a1: Unknown

device Mass storage controller (IDE interface) [1|1|85]
  vendor 197b: JMicron Technology Corp.
  device 2368: JMB368 IDE controller

device Bridge (PCI bridge, Normal decode) [6|4|0]
  vendor 1002: ATI Technologies Inc
  device 43a0: Unknown

device Serial bus controller (USB Controller, OHCI) [c|3|10]
  vendor 1002: ATI Technologies Inc
  device 4399: SB700/SB800 USB OHCI2 Controller

device Multimedia controller (Multimedia audio controller) [4|1|0]
  vendor 1412: VIA Technologies Inc.
  device 1712: ICE1712 [Envy24] PCI Multi-Channel I/O Controller

device Serial bus controller (FireWire (IEEE 1394), OHCI) [c|0|10]
  vendor 1106: VIA Technologies, Inc.
  device 3044: VT6306/7/8 [Fire II(M)] IEEE 1394 OHCI Controller

device Bridge (PCI bridge, Subtractive decode) [6|4|1]
  vendor 1002: ATI Technologies Inc
  device 4384: SBx00 PCI to PCI Bridge

device Bridge (ISA bridge) [6|1|0]
  vendor 1002: ATI Technologies Inc
  device 439d: SB700/SB800 LPC host controller

device Multimedia controller (Audio device) [4|3|0]
  vendor 1002: ATI Technologies Inc
  device 4383: SBx00 Azalia (Intel HDA)

device Mass storage controller (IDE interface) [1|1|8a]
  vendor 1002: ATI Technologies Inc
  device 439c: SB700/SB800 IDE Controller

device Serial bus controller (SMBus) [c|5|0]
  vendor 1002: ATI Technologies Inc
  device 4385: SBx00 SMBus Controller

device Serial bus controller (USB Controller, EHCI) [c|3|20]
  vendor 1002: ATI Technologies Inc
  device 4396: SB700/SB800 USB EHCI Controller

device Serial bus controller (USB Controller, OHCI) [c|3|10]
  vendor 1002: ATI Technologies Inc
  device 4397: SB700/SB800 USB OHCI0 Controller

device Serial bus controller (USB Controller, EHCI) [c|3|20]
  vendor 1002: ATI Technologies Inc
  device 4396: SB700/SB800 USB EHCI Controller

device Serial bus controller (USB Controller, OHCI) [c|3|10]
  vendor 1002: ATI Technologies Inc
  device 4397: SB700/SB800 USB OHCI0 Controller

device Mass storage controller (IDE interface) [1|1|8f]
  vendor 1002: ATI Technologies Inc
  device 4390: SB700/SB800 SATA Controller [IDE mode]

device Bridge (PCI bridge, Normal decode) [6|4|0]
  vendor 1002: ATI Technologies Inc
  device 597f: RD790 PCI to PCI bridge (PCI express gpp port F)

device Multimedia controller (Audio device) [4|3|0]
  vendor 1002: ATI Technologies Inc
  device aa58: Juniper HDMI Audio [Radeon HD 5700 Series]

device Display controller (VGA compatible controller, VGA controller) [3|0|0]
  vendor 1002: ATI Technologies Inc
  device 68b8: Juniper [Radeon HD 5700 Series]

device Bridge (PCI bridge, Normal decode) [6|4|0]
  vendor 1002: ATI Technologies Inc
  device 5978: RD790 PCI to PCI bridge (external gfx0 port A)

device Bridge (Host bridge) [6|0|0]
  vendor 1002: ATI Technologies Inc
  device 5957: RX780/RX790 Chipset Host Bridge
~> 

Attachments (3)

screenshot1.png (95.8 KB ) - added by stargatefan 8 years ago.
screenshot2.png (155.1 KB ) - added by stargatefan 8 years ago.
syslog (106.7 KB ) - added by stargatefan 8 years ago.

Download all attachments as: .zip

Change History (7)

by stargatefan, 8 years ago

Attachment: screenshot1.png added

by stargatefan, 8 years ago

Attachment: screenshot2.png added

comment:1 by mmlr, 8 years ago

Most probably the usual SB700/SB800 interrupt issues and therefore a duplicate of #5551. What does the syslog say?

comment:2 by mmlr, 8 years ago

Description: modified (diff)

by stargatefan, 8 years ago

Attachment: syslog added

comment:3 by stargatefan, 8 years ago

I attached the syslog. Let me know what you need in terms of hardware resources "if any" and I will provide them. This bug is really annoying and seems to effect alot of folks if it is the interupt issues in 5551.

comment:4 by mmlr, 8 years ago

Blocked By: 5551 added
Resolution: duplicate
Status: newclosed
Summary: USB disk drives "flash tumbs and usb 2.0 HDDs" not recognizedUSB disk drives "flash thumbs and usb 2.0 HDDs" not recognized

It's the same. Closing as a duplicate. I'm obviously aware of the impact of #5551, but it's kinda hard to debug and it probably would simply go away with using ACPI for IRQ routing, so it's questionable whether it's really worth it...

Note: See TracTickets for help on using tickets.