Opened 8 years ago

Closed 8 years ago

#7478 closed bug (duplicate)

[USB] Haiku does not boot on Gigabyte MA78LM-S2

Reported by: silentjohn Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/USB Version: R1/Development
Keywords: usb, sb700, sbx00, dummy_qh Cc:
Blocked By: #3999 Blocking:
Has a Patch: yes Platform: x86

Description

Boot hangs because of USB problem on my motherboard (Gigabyte MA78LM-S2, AMD780G/SB700) with hrev41280 and only the turning off the whole USB subsystem helps to prevent this issue.

I used a self-built hrev41280 gcc2hybrid nightly ISO with enabled USB tracing.

This ticket continues to solve issues described in ticket #4718.

Attachments (4)

lspcioutput (5.5 KB) - added by silentjohn 8 years ago.
usbdebug1.JPG (517.9 KB) - added by silentjohn 8 years ago.
usbdebug2.JPG (563.4 KB) - added by silentjohn 8 years ago.
ohci_disable_interrupts_early.diff (1.5 KB) - added by mmlr 8 years ago.

Download all attachments as: .zip

Change History (13)

Changed 8 years ago by silentjohn

Attachment: lspcioutput added

Changed 8 years ago by silentjohn

Attachment: usbdebug1.JPG added

Changed 8 years ago by silentjohn

Attachment: usbdebug2.JPG added

comment:1 Changed 8 years ago by anevilyak

Component: - GeneralDrivers/USB
Owner: changed from nobody to mmlr

Looks like a possible duplicate of #5551.

comment:2 Changed 8 years ago by mmlr

What exactly happens there? Does it stop there or does it continue very slowly? If it continues extremely slowly then it's either an OS interrupt storm or an SMI storm hanging or almost hanging the system due to it looping through the interrupt handlers continuously. Possibly disabling interrupts completely using the disable-interrupts register as well as acknowledging any possibly pending interrupt before writing the ownership change request could avoid that. It is also possible that the ownership change itself works, but the reset triggers the interrupt storm (would be pretty wired to implement it that way though).

comment:3 in reply to:  2 Changed 8 years ago by silentjohn

Replying to mmlr:

What exactly happens there? Does it stop there or does it continue very slowly? If it continues extremely slowly then it's either an OS interrupt storm or an SMI storm hanging or almost hanging the system due to it looping through the interrupt handlers continuously. Possibly disabling interrupts completely using the disable-interrupts register as well as acknowledging any possibly pending interrupt before writing the ownership change request could avoid that. It is also possible that the ownership change itself works, but the reset triggers the interrupt storm (would be pretty wired to implement it that way though).

It seems to me that boot halts completely. I can't confirm the extremely slow boot because I left it only for 1-2 minutes in this state. I can restart the machine only with pushing the reset button.

comment:4 Changed 8 years ago by mmlr

Keywords: dummy_qh added

This one might be related to/same as #3999. The quirk patch in #5551 doesn't apply to this, but one of the other quirks may (most promising would be the need for a dummy queue head to avoid a chipset problem that may otherwise read/write random memory on many ATI/AMD chipsets).

Changed 8 years ago by mmlr

comment:5 Changed 8 years ago by mmlr

Has a Patch: set

comment:6 Changed 8 years ago by mmlr

If it is an interrupt storm triggered by the handover then the attached patch might fix it. It disables the controller interrupts before most initialization happens, more specifically before handover and reset. Please try applying this and report back. The patch also cleans up some leftover comments that aren't true anymore since quite some time...

comment:7 Changed 8 years ago by silentjohn

My bad, the same issue like https://dev.haiku-os.org/ticket/3999#comment:5 :(

comment:8 Changed 8 years ago by stargatefan

I have been having similar issues to ticket #5551 and I filed a ticket about no functional usb2.0 ports. Although low speed stuff is working ok. I did try this patch due to a noticeable hang during boot and it has definately cured the boot hang. So this patch works to help resolve long boot times on AMD chipset.

There is still some issue with the 760g chipset SB ohci controller. I will attach the picture of the debugging output from boot tommorow and maybe it'll shed some light on this thorn.

comment:9 Changed 8 years ago by mmlr

Blocked By: 3999 added
Resolution: duplicate
Status: newclosed

As per comment:7 this is a duplicate of #3999.

Note: See TracTickets for help on using tickets.