Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#7527 closed bug (fixed)

User Guide and Welcome page not opened by double-clicking the respective links in Desktop

Reported by: taos Owned by: mmadia
Priority: normal Milestone: R1
Component: Build System Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #7547
Has a Patch: no Platform: All

Description

Using r1a3-rc-hrev41595 (but also true for r1a3-rc-hrev41552). Haiku is installed from raw image mounted on another Haiku partition via Installer to a microSD card.

When double-clicking the Desktop links "User Guide" or "Welcome" a message pops up and tells me that the page can't be opened because it's marked as executable. I'm given the option to proceed and let haiku fix this issue.

Message when double-clicking the links in desktop.

However, haiku doesn't remove the execution rights and the same message pops up again and again and...

Here screenshots of Get Info for the desktop link and html file:

Get Info of "User Guide" link. Get Info of the actual html file "contents.html".

I have to manually remove the execution rights to get User Guide opened by double-clicking on the desktop links.

The BeBook link works as intended. Welcome and User Guide links used to work in alpha2 (that's what I'm running on the second partition - it's only there for installation purposes).

It might be nice to resolve this issue for alpha 3 assuming the observed behaviour is not caused by my rather exotic way of installing haiku (I expect most people use either the iso or anyboot images).

Attachments (3)

UserGuide.png (8.5 KB ) - added by taos 8 years ago.
Message when double-clicking the links in desktop.
LinkInfo.png (15.8 KB ) - added by taos 8 years ago.
Get Info of "User Guide" link.
UserGuideInfo.png (16.9 KB ) - added by taos 8 years ago.
Get Info of the actual html file "contents.html".

Download all attachments as: .zip

Change History (9)

by taos, 8 years ago

Attachment: UserGuide.png added

Message when double-clicking the links in desktop.

by taos, 8 years ago

Attachment: LinkInfo.png added

Get Info of "User Guide" link.

by taos, 8 years ago

Attachment: UserGuideInfo.png added

Get Info of the actual html file "contents.html".

comment:1 by taos, 8 years ago

Version: R1/DevelopmentR1/alpha3

comment:2 by anevilyak, 8 years ago

Blocking: 7547 added

(In #7547) Duplicate of #7527.

comment:3 by mmadia, 8 years ago

Looking at the output of ls -lhaR | sed -n -e '/^-rwx/p' a mounted image file of r1a3-hrev41634-rc, it looks like any file that is copied from the repository into the image is getting a +x bit. I haven't checked what it looks like after booting said image though.

comment:4 by mmadia, 8 years ago

Component: DocumentationBuild System
Owner: changed from nielx to mmadia
Status: newassigned

... I'll look into this some more.

comment:5 by mmadia, 8 years ago

Resolution: fixed
Status: assignedclosed

A cron script on the build machine was responsible for changing the permissions. Fixed.

Edit: the next image after, haiku-r1a3-rc-hrev41612-raw.tar.xz should have the fixed permissions.

Last edited 8 years ago by mmadia (previous) (diff)

comment:6 by mmadia, 8 years ago

Version: R1/alpha3R1/Development

R1 Alpha 3 has not yet been released. This was with an R1 Alpha 3 Release Candidate image.

Note: See TracTickets for help on using tickets.