Opened 8 years ago

Last modified 6 years ago

#7591 reopened bug

[ShowImage] double click inside the app doesn't work right away after entering/leaving fullscreen

Reported by: diver Owned by: leavengood
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description


Change History (10)

comment:1 Changed 8 years ago by axeld

Could you describe what you mean, I have no clue? :-)

comment:2 Changed 8 years ago by diver

At least in VirtualBox if you double click an image inside the ShowImage to enter fullscreen mode you have to wait for 1 or 2 seconds before next double click (to leave fullscreen) would work, otherwise it just wouldn't react.

comment:3 Changed 8 years ago by axeld

You might have a long double click time, and the additional clicks could be counted to the first double click (ie. as triple click, etc.); at least there is nothing else that should prevent that from happen.

comment:4 Changed 8 years ago by diver

My double click time setting is the default one and changing it doesn't help.

comment:5 Changed 8 years ago by diver

I wonder, could #7282 be somehow related.

comment:6 Changed 8 years ago by diver

Reproducible on real hw.

comment:7 Changed 8 years ago by leavengood

Resolution: fixed
Status: newclosed

This happens because the click count can actually reach 4 or 6 pretty easily when rapidly double clicking. In that case the clicks are pretty much ignored.

But now it should be fixed in hrev42233.

comment:8 Changed 8 years ago by bonefish

I think this should better be solved generally in the app server. IIRC I already added a mechanism to reset the click count, when the view under the mouse changes in between clicks. This could be extended to also reset the click count, when the view remains the same, but has changed its size.

comment:9 Changed 8 years ago by leavengood

Component: Applications/ShowImageServers/app_server
Resolution: fixed
Status: closedreopened

Re-opening to fix it properly using Ingo's suggestion. Changing component to app_server.

comment:10 Changed 6 years ago by hometue

(GCI-2012 Participant) Haiku revision: hrev44702. Not valid, Even assigning just 100 MB ram to Haiku does not seems to cause any break between doubleclicks if I quickly click repeatively. System: Haiku R1-alpha4 on Virtualbox 4.1.20 on windows 7 64 bit

Note: See TracTickets for help on using tickets.