Opened 8 years ago

Closed 6 years ago

#7602 closed enhancement (fixed)

Intel HD Graphics not supported

Reported by: fano Owned by: axeld
Priority: normal Milestone: R1
Component: Drivers/Graphics/intel_extreme Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I've tried hrev41789 ("quasi" Alpha 3) and thanks to the "Display Preference" I've seen that Haiku was using VESA driver.

This GPU is embedded in the Intel Core I3 processor.

Intel Windows driver says that has: Vendor ID: 8086 Device ID: 0046

Syslog attached.

Attachments (1)

syslog.zip (48.2 KB ) - added by fano 8 years ago.

Download all attachments as: .zip

Change History (6)

by fano, 8 years ago

Attachment: syslog.zip added

comment:1 by tonestone57, 8 years ago

Type: bugenhancement
Version: R1/alpha3R1/Development

Not a bug. The Intel graphic driver does not support newer hardware. Just like Nvidia driver in Haiku that only works up to Geforce 79xx.

Supported Intel graphic cards:
http://dev.haiku-os.org/browser/haiku/trunk/src/add-ons/kernel/drivers/graphics/intel_extreme/driver.cpp#L40

Either writing new driver required for Intel HD graphics (or extend current one) to support them. In either case this is an enhancement.

Also, syslog should not be zipped when attaching to tickets.

Ticket switched to R1/Dev because not tested on official release of R1/A3 yet.

comment:2 by fano, 8 years ago

In our opinion is so similar to the other Intel model that it is sufficient to add the device id to the kSupportedDevices structure or need more modification or another driver altogheter for the Graphics HD (GMA-HD) family?

comment:3 by tonestone57, 8 years ago

Needs new driver or major code rewrite of current intel_extreme driver to support Intel HD. My laptop also has Intel HD so would be nice to have for me too to get 16x9 resolutions.

The hardware changed too much for Haiku's intel_extreme driver to support. Same thing with Nvidia. The Nvidia driver can only support from TNT1 to 79xx because 8xxx and newer Geforces needs major changes to the driver to work. Same with older Radeon driver in Haiku that works till X800. The newer RadeonHD driver should support new Radeon cards when finished.

Adding in the device id will not work if newer driver code is required. The changes between those other listed models were more minor but going to Intel HD was major hardware change. Same thing for Geforce & Radeon cards and why the drivers work for older graphic cards and not the newer ones out today. ie, anyone using newer graphics card is using VESA driver =)

comment:4 by fano, 8 years ago

Terrible!

GPU market is very confused indeed GPU with name similar that give the idea of be of the same family are not, and indeed model that have different names are rebrand of old models...

Well the positive thing is that Haiku VESA driver is very good it reach my monitor preferred resolution: 1280x1024... if it not was for the new info in "Display Preference" it is very difficult to know you're not using the driver... at least if you not need the exotic laptop resolution.

comment:5 by korli, 6 years ago

Resolution: fixed
Status: newclosed

This device should be supported in current revisions (~hrev45822). Please reopen if needed.

Note: See TracTickets for help on using tickets.