Opened 8 years ago

Closed 5 years ago

#7636 closed bug (fixed)

Crash when scrolling file extensions

Reported by: humdinger Owned by: axeld
Priority: normal Milestone: R1
Component: Preferences/FileTypes Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is R1/alpha3 rc, hrev41843.

  • Open FileTypes prefs
  • Show e.g. audio/mpeg
  • Activate "Show recognition rule" from the settings menu (as an aside: see the layout getting messed up)
  • Scroll the extension list up and down by clicking the arrow buttons -> OK
  • Scroll the extension list by grabbing the scroll knob -> Crash!

Backtrace:

[tcsetpgrp failed in terminal_inferior: Invalid Argument]
Thread 378 caused an exception: Segment violation
   [snip]
[Switching to team /boot/system/preferences/FileTypes (371) thread w>FileTypes (378)]
0x0031de4a in BPrivate::LinkSender::Attach () from /boot/system/lib/libbe.so
(gdb) bt
#0  0x0031de4a in BPrivate::LinkSender::Attach ()
   from /boot/system/lib/libbe.so
#1  0x00338257 in long BPrivate::ServerLink::Attach<long> ()
   from /boot/system/lib/libbe.so
#2  0x003ea6a9 in BView::_SwitchServerCurrentView ()
   from /boot/system/lib/libbe.so
#3  0x003ea616 in BView::_CheckLockAndSwitchCurrent ()
   from /boot/system/lib/libbe.so
#4  0x003e659d in BView::Invalidate () from /boot/system/lib/libbe.so
#5  0x003a81f6 in BScrollBar::_UpdateThumbFrame ()
   from /boot/system/lib/libbe.so
#6  0x003a4fbe in BScrollBar::SetValue () from /boot/system/lib/libbe.so
#7  0x003e1132 in BView::ScrollTo () from /boot/system/lib/libbe.so
#8  0x0037b0c5 in BListView::ScrollTo () from /boot/system/lib/libbe.so
#9  0x003e0f1e in BView::ScrollBy () from /boot/system/lib/libbe.so
#10 0x003a507d in BScrollBar::ValueChanged () from /boot/system/lib/libbe.so
#11 0x003a4fee in BScrollBar::SetValue () from /boot/system/lib/libbe.so
#12 0x003e1132 in BView::ScrollTo () from /boot/system/lib/libbe.so
#13 0x0037b0c5 in BListView::ScrollTo () from /boot/system/lib/libbe.so
#14 0x003e0f1e in BView::ScrollBy () from /boot/system/lib/libbe.so
#15 0x003a507d in BScrollBar::ValueChanged () from /boot/system/lib/libbe.so
#16 0x003a4fee in BScrollBar::SetValue () from /boot/system/lib/libbe.so
#17 0x003e1132 in BView::ScrollTo () from /boot/system/lib/libbe.so
#18 0x0037b0c5 in BListView::ScrollTo () from /boot/system/lib/libbe.so
---Type <return> to continue, or q <return> to quit---
#19 0x003e0f1e in BView::ScrollBy () from /boot/system/lib/libbe.so
#20 0x003a507d in BScrollBar::ValueChanged () from /boot/system/lib/libbe.so
#21 0x003a4fee in BScrollBar::SetValue () from /boot/system/lib/libbe.so
#22 0x003e1132 in BView::ScrollTo () from /boot/system/lib/libbe.so
#23 0x0037b0c5 in BListView::ScrollTo () from /boot/system/lib/libbe.so
#24 0x003e0f1e in BView::ScrollBy () from /boot/system/lib/libbe.so
#25 0x003a507d in BScrollBar::ValueChanged () from /boot/system/lib/libbe.so
#26 0x003a4fee in BScrollBar::SetValue () from /boot/system/lib/libbe.so
#27 0x003e1132 in BView::ScrollTo () from /boot/system/lib/libbe.so
#28 0x0037b0c5 in BListView::ScrollTo () from /boot/system/lib/libbe.so
#29 0x003e0f1e in BView::ScrollBy () from /boot/system/lib/libbe.so
#30 0x003a507d in BScrollBar::ValueChanged () from /boot/system/lib/libbe.so
#31 0x003a4fee in BScrollBar::SetValue () from /boot/system/lib/libbe.so
#32 0x003e1132 in BView::ScrollTo () from /boot/system/lib/libbe.so
#33 0x0037b0c5 in BListView::ScrollTo () from /boot/system/lib/libbe.so
#34 0x003e0f1e in BView::ScrollBy () from /boot/system/lib/libbe.so
#35 0x003a507d in BScrollBar::ValueChanged () from /boot/system/lib/libbe.so

[... and so on and on and on ...]

Change History (1)

comment:1 Changed 5 years ago by humdinger

Resolution: fixed
Status: newclosed

Can't reproduce anymore. Closing as fixed...

Note: See TracTickets for help on using tickets.