Opened 8 years ago

Closed 7 years ago

#7637 closed bug (fixed)

[WebPositive] Frame borders around pop-up menus missing in fonts settings tab.

Reported by: taos Owned by: leavengood
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Using r1a3-rc-hrev41884 with WebPositive hrev580.

Frame borders are missing around pop-up menus in fonts settings dialog (Window -> Settings -> Fonts):

Screenshot of WebPositive's fonts settings tab.

Pop-up menus in general settings tab show frame borders:

Screenshot of WebPositive's general settings tab.

Attachments (2)

WebPositive_Fonts.png (31.1 KB) - added by taos 8 years ago.
Screenshot of WebPositive's fonts settings tab.
WebPositive_General.png (31.3 KB) - added by taos 8 years ago.
Screenshot of WebPositive's general settings tab.

Download all attachments as: .zip

Change History (9)

Changed 8 years ago by taos

Attachment: WebPositive_Fonts.png added

Screenshot of WebPositive's fonts settings tab.

Changed 8 years ago by taos

Attachment: WebPositive_General.png added

Screenshot of WebPositive's general settings tab.

comment:1 Changed 8 years ago by leavengood

Status: newin-progress

That's weird, good catch. I'll have to see but it must be related to how that page is set up with the layout system.

comment:2 Changed 8 years ago by leavengood

If you compare to Web+ hrev577 (the last released version) you can see that the labels are also missing on this page in hrev580 (and in your screenshot.) This is really weird because no code was changed related to the font settings in revisions 578, 579 or 580. Something must be wonky in my build. I'll have to re-release once I fix this.

comment:3 Changed 8 years ago by mmadia

Version: R1/alpha3R1/Development

R1 Alpha 3 has not yet been released. This was with an R1 Alpha 3 Release Candidate image.

comment:4 Changed 7 years ago by taos

Using hrev43740 (gcc2hybrid) with Web+ hrev583.

The problem is still there.

comment:5 Changed 7 years ago by diver

Might be related to #3499.

comment:6 Changed 7 years ago by taos

Using hrev44418 (gcc2hybrid).

Fonts settings tab looks okay now.

comment:7 Changed 7 years ago by leavengood

Resolution: fixed
Status: in-progressclosed

Yes this was fixed by Rene and patched into WebPositive by Alexander Deckner before it was moved into the Haiku sources. So there is no exact href for it.

Note: See TracTickets for help on using tickets.