Opened 8 years ago

Closed 4 years ago

#7648 closed bug (duplicate)

[Tracker] orphaned disk icons on the Desktop after moving icon before un-mount

Reported by: ribbonz Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Tracker Version: R1/Development
Keywords: Cc:
Blocked By: #5593 Blocking: #7821
Has a Patch: no Platform: All

Description

open Terminal
cd 'to/some/directory/on/a/drive/with/plenty/of/space'

dd if=/dev/zero of=daddy.img bs=1M count=1000
settype -t 'application/x-bfs-image' daddy.img
mkfs -t bfs daddy.img daddy
open daddy.img

This gives us a new 1000MB disk image that is mounted, with an icon on the Desktop, and ready to be used. Now right-click on the Desktop and select 'daddy' from the popup menu to Unmount the image.

We are now ready to...

[Do the Dance]

  1. right-click on the Desktop and select 'daddy' to mount the disk again
  2. after the disk icon appears, move it to another location: doesn't need to be too far away -- preferably not aligned neatly to where it was moved from
  3. right-click on the icon itself and select 'Unmount' to unmount it

Most often, the icon stays on-screen after step 3, even though it's unmounted. If the icon does disappear, then 'Do the Dance' again.

Now that you have an orphaned icon on the Desktop, the next time you remount it it will appear in the same place the last one got stranded at. Just drag the icon to a new location (will reveal the stuck one underneath) You now have two 'daddy' icons...

[repeat as often as you like]

It appears that Tracker is expecting the icon to stay put, so moving it away before unmounting it seems to confuse Tracker's display logic.

The attached screenshot is not a photoshopped image or anything like that. With a little practice, it becomes easy to reproduce -- so I had a little fun and made of bunch of orphaned icons.

I've seen this before on normal disk images, so I don't think it has anything to do with "virtual disks". Just made for an easy-to-test case.

Attachments (3)

many_daddys.png (115.7 KB) - added by ribbonz 8 years ago.
many 'daddy's on the desktop
happy_mommys.png (103.1 KB) - added by ribbonz 8 years ago.
screenshot1.png (20.4 KB) - added by vidrep 5 years ago.

Download all attachments as: .zip

Change History (10)

Changed 8 years ago by ribbonz

Attachment: many_daddys.png added

many 'daddy's on the desktop

comment:1 Changed 8 years ago by anevilyak

I'm unable to reproduce this behavior here. Are you booting Haiku off a hard disk, USB stick or what here? In any case, the icon positioning should be completely irrelevant here, it sounds more like the device removal notification isn't being sent/received properly in some cases, which is what Tracker depends on to know to remove the icon.

comment:2 Changed 8 years ago by ribbonz

anevilyak, I'm booting off a hard drive

revision 41667 (R1A3)

I just went and tried it on my other computer, which also has a Haiku partition. Also revision 41667. Had no problem creating orphaned icons, at all. Stranded icons all over the place.

I'm getting pretty good at it. Maybe I should attach another picture, with a bunch of 'mommy' disk icons -- just to be fair. Really, I'm becoming quite proficient with this. Actually, it's kind of fun... Maybe we should leave it in, and if someone stumbles upon it, just say that it's an Easter egg.

comment:3 Changed 8 years ago by ribbonz

ok, I had to go ahead and make a 'mommy's picture...

Changed 8 years ago by ribbonz

Attachment: happy_mommys.png added

comment:4 Changed 7 years ago by jessicah

I'm also experiencing this with hrev44346. Haiku is installed to the HDD, and using a USB pen drive with an anyboot image on it.

First time I mounted the anyboot image, the icon for the USB overlaid the system's Haiku icon. When unmounting, the icon would change to the cabinet icon with an empty bar. Successive mounting/unmounting creates more of these such icons. And the icons cannot be deleted either.

Changed 5 years ago by vidrep

Attachment: screenshot1.png added

comment:5 Changed 5 years ago by vidrep

Bug still present in 46523_x86_64

comment:6 Changed 4 years ago by diver

Blocking: 7821 added

comment:7 Changed 4 years ago by diver

Blocked By: 5593 added
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.