Opened 8 years ago

Closed 5 years ago

#7821 closed bug (duplicate)

Two HAIKU USB sticks

Reported by: Arnold Owned by: mmlr
Priority: normal Milestone: R1
Component: Drivers/USB Version: R1/alpha3
Keywords: stick icon becomes cabinet icon Cc:
Blocked By: #7648 Blocking: #10318
Has a Patch: no Platform: All

Description (last modified by diver)

Started up HAIKU from USB with hrev42421 (Behaviour also seen on R1A3) Then mount another USB with HAIKU (R1A3 used) Icon (USB-stick) is placed on top of HAIKU-icon of the system. Move this to its own location for better vision. Browse files from HAIKU USB (stick) then unmount the HAIKU USB stick. The icon changes from a stick to a cabinet. Try to remove the cabinet to trash because stick is already unmounted. This is not possible.

Attachments (1)

screenshot1.png (68.4 KB ) - added by vidrep 5 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 by deejam, 8 years ago

Then mount another USB with HAIKU (R1A3 used) Icon (USB-stick) is placed on top of HAIKU-icon of the system.

This part of this ticket sound like its a duplicate of #2864.

in reply to:  1 comment:2 by diver, 8 years ago

Component: - GeneralDrivers/USB
Description: modified (diff)
Owner: changed from nobody to mmlr

comment:3 by diver, 5 years ago

Blocking: 10318 added

(In #10318) It's likely a dupe of #7821.

comment:4 by vidrep, 5 years ago

This is still an issue with latest revision. See attached screenshot. In this case mounting another Haiku partition, then unmounting causes the cabinet icon to appear. It cannot be deleted from the desktop.

Last edited 5 years ago by vidrep (previous) (diff)

by vidrep, 5 years ago

Attachment: screenshot1.png added

comment:5 by diver, 5 years ago

Does restarting Tracker make it go away?

comment:6 by vidrep, 5 years ago

If I kill the Tracker using process controller, then restore the Desktop from Team Monitor the icon goes away.

comment:7 by diver, 5 years ago

Blocked By: 7648 added
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.