Opened 8 years ago

Closed 8 years ago

#7652 closed enhancement (duplicate)

[Deskbar] Calendar is not localized

Reported by: deejam Owned by: zooey
Priority: normal Milestone: R1
Component: Kits/Locale Kit Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #7947
Has a Patch: no Platform: All

Description

The calendar in Deskbar is not localized.

r1a3-rc-hrev41884.

As seen in the image below, the month and days of the week are not localized.

Attachments (1)

deskbar_calendar_not_localized.png (13.2 KB ) - added by deejam 8 years ago.

Download all attachments as: .zip

Change History (5)

by deejam, 8 years ago

comment:1 by taos, 8 years ago

Calendar in time preflet is also not localized.

comment:2 by diver, 8 years ago

BTW, calendar layout is different from time preflet. Would be nice to unify them.

comment:3 by pulkomandy, 8 years ago

Component: Applications/DeskbarKits/Locale Kit
Owner: changed from axeld to zooey
Status: newassigned

Both Deskbar and Time preferences use BCalendarView, which in turn uses strftime for getting the weekdays and month names. So I guess it's a problem with strftime not working properly (ie localized) in that case ?

comment:4 by pulkomandy, 8 years ago

Blocking: 7947 added
Resolution: duplicate
Status: assignedclosed

Duplicate of #7947.

Note: See TracTickets for help on using tickets.