Opened 8 years ago

Closed 8 years ago

#7681 closed bug (fixed)

BListView ScrollToSelection Broken Under Layout Management

Reported by: leavengood Owned by: anevilyak
Priority: normal Milestone: R1
Component: Kits/Interface Kit Version: R1/Development
Keywords: Cc: yourpalal2@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I am testing on hrev41768 (a pure GCC4 R1A3 RC), but the Time changes I'm testing on are from hrev42100.

In the Time preferences the time zone list does not properly scroll to the selected time zone now that the GUI is under layout management. Adding a second call to ScrollToSelection (see attached patch) fixes the issue. Humdinger made note of this issue too, so I don't think it is due to my version of Haiku.

Since this hack is not a proper fix I'm logging this bug so that people more knowledgeable about layout management can take a look.

Attachments (1)

scroll_to_selection_hack.patch (559 bytes ) - added by leavengood 8 years ago.
Patch to Time which is a hack (NOT a fix to this ticket)

Download all attachments as: .zip

Change History (3)

by leavengood, 8 years ago

Patch to Time which is a hack (NOT a fix to this ticket)

comment:1 by anevilyak, 8 years ago

Owner: changed from axeld to anevilyak
Status: newin-progress

Looking into it.

comment:2 by anevilyak, 8 years ago

Resolution: fixed
Status: in-progressclosed

Fixed in hrev42106. The problem is, AllAttached() is too early to be doing that kind of thing when in layout mode, since the layout isn't computed until the layout has been completely built (AllAttached() only signifies that all the children of the current view have been attached to the window). Thus ScrollToSelection() was computing a completely bogus coordinate based off the fact that the view was 0 size at that point.

Note: See TracTickets for help on using tickets.