Opened 8 years ago

Closed 8 years ago

#7680 closed bug (duplicate)

No sound with HDA on intel N10 (NM10 Express chipset)

Reported by: 6foot3 Owned by: korli
Priority: normal Milestone: R1
Component: Drivers/Audio/HDA Version: R1/Development
Keywords: Cc:
Blocked By: #7144 Blocking:
Has a Patch: no Platform: x86

Description

Media preferences looks sort of normal to me. Movies and mp3 are played by the media player and the sound level meters show as if audio should be heard. Strangely enough, my desktop which uses a desktop version of the same chip and chipset family, Intel Atom Pine Trail has no issues whatsoever. The netbook uses the Atom N450 while the desktop uses the D525 and they both use an Intel NM10 Express chipset. Intel claims to have shipped 100 million Atom cpus over the last three years.

In light of ticket #7666, I thought I should open this ticket. I also see similar behaviour on my laptop so I'm guessing that this is a fairly common issue. If I should not be opening this as a separate ticket please let me know what I should do

Attachments (2)

listdev_output_20110610.txt (2.4 KB ) - added by 6foot3 8 years ago.
syslog_r42061_no_sound.txt (226.8 KB ) - added by 6foot3 8 years ago.

Download all attachments as: .zip

Change History (5)

by 6foot3, 8 years ago

Attachment: listdev_output_20110610.txt added

by 6foot3, 8 years ago

Attachment: syslog_r42061_no_sound.txt added

comment:1 by luroh, 8 years ago

Component: Audio & VideoDrivers/Audio/HDA
Owner: changed from nobody to korli

A search for your audio device id 27d8 comes up with the following possible duplicates: #4492, #4635, #4755 (messy ticket), #6213 and #7144. Could you please check if any of those tickets match your problem?

comment:2 by 6foot3, 8 years ago

Not #4492, no sound from either headphones or internal speakers and different chipset (Intel 82801G). Not #4635, again Intel 82801G. #4755? Maybe but, the creator of that ticket did not supply a listdev output so, without digging through the syslogs, we really don't know what hardware haiku thinks is there. The last comment as of 2011-06-11 seems to summarize the problem/challenge.

Not #6213 as this relates to one of the desktop versions of the cpu/chipset family. I've used both an earlier version (Intel D945GCLF2) and a more recent version (Intel D525MW) of the same cpu/chipset with absolutely no issues apart from an intel_extreme driver issue that was fixed some time ago. I seriously doubt that this ticket is still valid. I last used my D525MW motherboard based system yesterday with hrev42061 and AFAIK the only difference between the D510 and the D525 is the speed, 1.66 vs 1.80 GHz.

#7144 is pretty much an exact match but, the last comment suggests using the opensound optional package as a workaround.

I guess this ticket should be marked as a duplicate of #7144.

I also have a full size latop which was the subject of ticket #5866 that also has this problem. That ticket had to do with IO-APIC issues that have now been solved. Would IO-APIC issus affect the ability of the HDA driver to interact with the hardware? If so, maybe it's time to revisit the HDA driver since the amount of systems affected by this issue is potentially huge.

In terms of different hadware affected by the same bug, is it useful for the devs to have listdev outputs and syslogs for more than one computer that experiences a similar bug? I'm getting a new charger for my laptop today and want to know if the listdev output and the latest syslog would be of use to anyone?

in reply to:  2 comment:3 by luroh, 8 years ago

Blocked By: 7144 added
Resolution: duplicate
Status: newclosed

#7144 is pretty much an exact match but, the last comment suggests using the opensound optional package as a workaround.

Right, if it works, that could serve as a workaround until the HDA driver has gained support for the device. Closing as duplicate of #7144. Thanks for checking.

Note: See TracTickets for help on using tickets.