Opened 8 years ago

Closed 8 years ago

#7690 closed bug (invalid)

Regression: Unhandled interrupts on ICH9 system (was acpi_battery no longer being loaded)

Reported by: brecht Owned by: mmlr
Priority: high Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: yes Platform: All

Description

At this point, I can only say it's in a build newer than R1A2. I can do a binary search later, if needed.

The attached syslog shows the KDL ints output at the end (right after a fresh boot).

Attachments (5)

syslog (182.2 KB ) - added by brecht 8 years ago.
listdev.txt (3.2 KB ) - added by brecht 8 years ago.
ints.txt (3.8 KB ) - added by brecht 8 years ago.
KDL ints output after a while
no_io_apic_syslog (182.3 KB ) - added by brecht 8 years ago.
syslog with disabled IO APIC
no_io_apic_ints.txt (3.4 KB ) - added by brecht 8 years ago.
KDL ints after a while for IO APIC disabled

Download all attachments as: .zip

Change History (15)

by brecht, 8 years ago

Attachment: syslog added

by brecht, 8 years ago

Attachment: listdev.txt added

by brecht, 8 years ago

Attachment: ints.txt added

KDL ints output after a while

comment:1 by tqh, 8 years ago

Owner: changed from tqh to mmlr
Priority: normalhigh
Status: newassigned
Summary: acpi_battery no longer being loadedRegression: Unhandled interrupts on ICH9 system (was acpi_battery no longer being loaded)

The new int handling seems to be the problem for you.

comment:2 by tqh, 8 years ago

Component: Drivers/ACPISystem/Kernel

in reply to:  1 comment:3 by mmlr, 8 years ago

Replying to tqh:

The new int handling seems to be the problem for you.

Before jumping to conclusions there's a convenient way to verify that assumption: Try explicitly disabling IO-APICs in the safe mode options of the boot loader and check if that resolves the problem.

Also the changed ticket summary is rather misleading. From the ints output there's not any unusally high number of unhandled interrupts present.

comment:4 by tqh, 8 years ago

I'm sorry but that's the way I saw it. 2.7 million unhandled ints for int 219 sound very high to me.

in reply to:  4 comment:5 by mmlr, 8 years ago

Replying to tqh:

I'm sorry but that's the way I saw it. 2.7 million unhandled ints for int 219 sound very high to me.

Indeed, and that should probably be investigated as well. However this is not unusal at all and since it is a local interrupt source (generated and handled completely inside the local APIC / CPU) this wasn't affected by the interrupt routing changes (as it's not a routed interrupt).

by brecht, 8 years ago

Attachment: no_io_apic_syslog added

syslog with disabled IO APIC

comment:6 by brecht, 8 years ago

Has a Patch: set

by brecht, 8 years ago

Attachment: no_io_apic_ints.txt added

KDL ints after a while for IO APIC disabled

comment:7 by brecht, 8 years ago

Still no acpi_battery when IO APIC is disabled (this is related, right?). acpi_battery was already missing in hrev41281, when IO APIC was disabled by default.

Last edited 8 years ago by brecht (previous) (diff)

comment:8 by brecht, 8 years ago

acpi_battery loads again in hrev42209. Could've been something wrong with my install?

comment:9 by tqh, 8 years ago

It is quite likely as nothing had changed with regards to ACPI or acpi_battery. The only thing I thought was weird was ints, but as mmlr explained they are probably not related.

Shall we close this one?

in reply to:  9 comment:10 by mmlr, 8 years ago

Resolution: invalid
Status: assignedclosed

Replying to tqh:

Shall we close this one?

Yes, as nothing changed and the install was an "update-all" install, something being outdated was most likely the cause.

Note: See TracTickets for help on using tickets.