Opened 8 years ago

Closed 6 years ago

#7734 closed bug (fixed)

Fading in toolbar in full screen mode kills toolbar in window mode

Reported by: humdinger Owned by: leavengood
Priority: normal Milestone: R1
Component: Applications/ShowImage Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: yes Platform: All

Description

This is hrev42282.

Do this:

  • Open an image in ShowImage
  • Make sure the toolbar is showing
  • Enter full screen mode with ALT+ENTER
  • Move the mouse to fade in the toolbar
  • Wait until the toolbar disappears again and switch back to window mode with ALT+ENTER (if you switch while the toolbar is still showing, everything works as expected)

-> Now in window mode, the toolbar is gone and instead the 32(?) lines of the image are repeated:

Toolbar destroyed after full screen mode

Attachments (4)

ShowImage_toolbar-bug.png (209.4 KB) - added by humdinger 8 years ago.
Toolbar destroyed after full screen mode
showimage.png (66.0 KB) - added by diver 7 years ago.
softshapeart_sw_1600x1200.jpg (106.0 KB) - added by diver 7 years ago.
0001-Fix7734.-Avoid-race-conditions-in-ToolBar-animation.patch (3.1 KB) - added by Janus 7 years ago.

Download all attachments as: .zip

Change History (14)

Changed 8 years ago by humdinger

Attachment: ShowImage_toolbar-bug.png added

Toolbar destroyed after full screen mode

comment:1 Changed 8 years ago by leavengood

Resolution: fixed
Status: newclosed

Fixed in hrev42306.

comment:2 Changed 7 years ago by diver

Resolution: fixed
Status: closedreopened

I can still reproduce it in hrev44434 with the following steps:

  • Open an image in ShowImage
  • Enter full screen mode with double click
  • Make sure the toolbar is showing
  • Move the mouse to fade in the toolbar
  • When the toolbar starts disappearing switch back to window mode with double click

Last edited 7 years ago by diver (previous) (diff)

Changed 7 years ago by diver

Attachment: showimage.png added

comment:3 Changed 7 years ago by leavengood

With some effort (including making VirtualBox really slow) I was able to reproduce diver's latest version of this, but it is pretty hard to do, so I may put this bug in my low priority list. Eventually some sort of class could be added to manage the state and animating of the toolbar button, and maybe that could help avoid these issues (which really are just a form of race condition.)

comment:4 Changed 7 years ago by diver

I can reproduce it easily on real hardware.

Changed 7 years ago by diver

comment:5 Changed 7 years ago by diver

The other way to reproduce it is just to open this image in window mode and hold Atl+T for several seconds.

comment:6 Changed 7 years ago by Janus

Has a Patch: set

comment:7 Changed 7 years ago by Janus

Last edited 7 years ago by Janus (previous) (diff)

comment:8 Changed 7 years ago by Janus

Still a small race condition in transition from fullscreen to window (toolbar hidden). This is very hard to fix.

comment:9 Changed 6 years ago by axeld

Applied in hrev45249, thanks a lot! Not sure if it's worth to keep this bug open -- opinions?

comment:10 Changed 6 years ago by diver

Resolution: fixed
Status: reopenedclosed

Can't reproduce anymore, closing. Thanks!

Note: See TracTickets for help on using tickets.