Opened 8 years ago

Closed 8 years ago

#7748 closed bug (duplicate)

MarkAsRead sets status but not "read" attribute

Reported by: humdinger Owned by: nobody
Priority: normal Milestone: R1
Component: Add-Ons/Tracker Version: R1/alpha3
Keywords: Cc:
Blocked By: #7458 Blocking:
Has a Patch: yes Platform: All

Description

This is alpha3.

The Tracker add-on to set an email to "read" only changes the MAIL:status attribute to "Read", but leaves the MAIL:read attrbute untouched. Consequently, the Deskbar mailbox shows over 100,000 new mails, after I embarked on the misadventure to pop3 and later imap all my years of email to a new partition... And that doesn't change after invoking the "Mark as read" add-on on all of them.

Attached is a patch that should correct the add-ons' behaviour. I'd feel better if someone could look over it first before I commit it.

Thanks!

Attachments (1)

MarkAsRead.diff (1.2 KB ) - added by humdinger 8 years ago.
patch to also set MAIL:read to B_READ

Download all attachments as: .zip

Change History (3)

by humdinger, 8 years ago

Attachment: MarkAsRead.diff added

patch to also set MAIL:read to B_READ

comment:1 by humdinger, 8 years ago

Has a Patch: set

comment:2 by axeld, 8 years ago

Blocked By: 7458 added
Resolution: duplicate
Status: newclosed

Duplicate of #7458 (which also has a patch set, and more information).

Note: See TracTickets for help on using tickets.