Opened 8 years ago

Closed 8 years ago

#7779 closed bug (fixed)

[Time] crashes in BListItem::OutlineLevel ()

Reported by: diver Owned by: leavengood
Priority: normal Milestone: R1
Component: Preferences/Time & Date Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev42356, gcc2hybrid.

Time crashes on launch in Russian locale:

Thread 612 caused an exception: Segment violation
[...]
[Switching to team /boot/system/preferences/Time (612) thread Time (612)]
0x0035e572 in BListItem::OutlineLevel () from /boot/system/lib/libbe.so
(gdb) bt
#0  0x0035e572 in BListItem::OutlineLevel () from /boot/system/lib/libbe.so
#1  0x002207d9 in TimeZoneView::_BuildZoneMenu ()
#2  0x0021ea98 in TimeZoneView::_InitView ()
#3  0x0021e145 in TimeZoneView::TimeZoneView ()
#4  0x0021c7be in TTimeWindow::_InitWindow ()
#5  0x0021c382 in TTimeWindow::TTimeWindow ()
#6  0x0021badc in TimeApplication::TimeApplication ()
#7  0x0021be33 in main ()
(gdb)

Change History (2)

comment:1 Changed 8 years ago by diver

Owner: changed from axeld to leavengood
Status: newassigned

comment:2 Changed 8 years ago by diver

Resolution: fixed
Status: assignedclosed

Can't reproduce anymore, probably fixed in the meantime.

Note: See TracTickets for help on using tickets.