Opened 8 years ago

Closed 5 years ago

#7789 closed bug (invalid)

Can no longer connect to WEP protected hotspot

Reported by: deejam Owned by: mmlr
Priority: normal Milestone: R1
Component: Network & Internet/Wireless Version: R1/alpha3
Keywords: Cc: black.belt.jimmy@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I have previously been able to connect to a WEP protected network (named Haiku), but it has stopped working.

It used to connect on startup using the wireless_networks config file. I can connect in Windows on the same computer, and on other computers/smartphones. I have changed the passphrase, renamed the wifi network etc, but with no luck.

There are more users that has described the same problem on the forums.

I'll attach the syslog.

Attachments (1)

syslog (466.0 KB) - added by deejam 8 years ago.

Download all attachments as: .zip

Change History (9)

Changed 8 years ago by deejam

Attachment: syslog added

comment:1 Changed 8 years ago by bbjimmy

Cc: black.belt.jimmy@… added

comment:2 Changed 8 years ago by deejam

Is this issue fixed with the wpa_supplicant? If so, this ticket should be closed.

I cannot verify it at the moment, because the affected laptop is at my mothers house...

comment:3 in reply to:  2 Changed 8 years ago by mmlr

Replying to deejam:

Is this issue fixed with the wpa_supplicant? If so, this ticket should be closed.

Yes and no. For one the wpa_supplicant does support connecting to a WEP network, so yes. But on the other hand the request doesn't seem to go through to it right now, probably due to some wrong/incomplete net_server changes I did. So right now if you try to select a WEP network, nothing happens at all. Using ifconfig /dev/net/... join x you can actually get a wpa_supplicant dialog and then use the network name field to actually join your desired network. I still need to investigate that one.

comment:4 Changed 8 years ago by deejam

mmlr: Are you willing to take ownership of this ticket?

comment:5 in reply to:  4 Changed 8 years ago by mmlr

Component: - GeneralNetwork & Internet/Wireless
Owner: changed from nobody to mmlr
Status: newin-progress

Replying to deejam:

mmlr: Are you willing to take ownership of this ticket?

Sure. I looked into it once already but the problem wasn't immediately obvious.

comment:6 Changed 7 years ago by diver

Probably a dupe of #7840. It also contains a patch.

comment:7 Changed 6 years ago by diver

Is this still an issue?

comment:8 Changed 5 years ago by luroh

Resolution: invalid
Status: in-progressclosed

Possibly fixed, closing due to lack of feedback.

Note: See TracTickets for help on using tickets.