Opened 10 years ago

Closed 2 years ago

#7791 closed bug (fixed)

Streaks across screen with Intel 4500 MHD video card

Reported by: izomiac Owned by: nobody
Priority: normal Milestone: R1/beta2
Component: Drivers/Graphics/intel_extreme Version: R1/alpha3
Keywords: Cc:
Blocked By: Blocking:
Platform: x86

Description

See attached files for photos of the screen (ignore horizontal scan lines). This is a bit of a strange graphical error, there are well defined vertical streaks down the screen where colors (not black & white) are incorrect. Additionally, most images have halos and such around them. Oddly enough, the glitches seem to affect some peripheral pixels, but not all, with the affected pixels generally being brighter.

I believe one would call this a regression, since I just checked an old version of Senryu and saw the same halos, just far less pronounced, and I don't recall this bug existing in Alpha 1.

Attachments (3)

IMG_20110706_140700.jpg (1.6 MB ) - added by izomiac 10 years ago.
Screen Photo
IMG_20110706_140714.jpg (2.0 MB ) - added by izomiac 10 years ago.
Close-up on "H" on Haiku wallpaper
Logs.txt (5.8 KB ) - added by izomiac 10 years ago.
listdev && grep -i intel_extreme /var/log/syslog && listimage | grep drivers/

Change History (8)

by izomiac, 10 years ago

Attachment: IMG_20110706_140700.jpg added

Screen Photo

by izomiac, 10 years ago

Attachment: IMG_20110706_140714.jpg added

Close-up on "H" on Haiku wallpaper

by izomiac, 10 years ago

Attachment: Logs.txt added

listdev && grep -i intel_extreme /var/log/syslog && listimage | grep drivers/

comment:1 by axeld, 4 years ago

Owner: changed from axeld to nobody
Status: newassigned

comment:2 by pulkomandy, 3 years ago

Milestone: R1R1/beta2

comment:3 by waddlesplash, 2 years ago

Please retest after hrev53040.

in reply to:  3 comment:4 by izomiac, 2 years ago

Replying to waddlesplash:

Please retest after hrev53040.

Sorry for the slow reply, I had to dig my old laptop out of the closet and find a working power cord. It would appear this issue has been solved for me.

Sadly it doesn't seem like I can change resolution up or down (up -- right side goes off the screen edge, down -- some weird mosaic that reminds me of one of those sliding block puzzles, where blocks of ~300 px x 100 px are in random order). But the colors are correct at least! Plus I can use it at 1024x768, albeit with stretching for the widescreen.

comment:5 by waddlesplash, 2 years ago

Resolution: fixed
Status: assignedclosed

There are other tickets tracking those issue I believe. So, this one is solved at any rate, excellent!

Note: See TracTickets for help on using tickets.