Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#78 closed bug (duplicate)

another cache bug, maybe same as 77

Reported by: stippi Owned by: axeld
Priority: blocker Milestone: R1
Component: System/Kernel Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Tried to expand the WonderBrush2.0 zip file with Expander. The zip file double clicked in Tracker is not automatically loaded in Expander, but drag&drop works good enough to load the zip into Expander. When I clicked Expand, I was soon visiting KDL:

unhandled page fault in kernel space... sc: <kernel> ChunkIndex11block_rangeP11block_cachePv + 0x000d <kernel> Free11block_rangeP11block_cacheP11 + 0x001d <kernel> Free11block_cachePv + 0x002a <kernel> cache_start_sub_transaction + 0x00d6 <bfs> Lock7JournalP11Transaction + 0x00b0 <bfs> Start11TransactionP6Volumex + 0x0028 <bfs> bfs_free_cookie_FPvN20 + 0x0165 <kernel> file_free_fd_FP15file_descriptor + 0x0031 <kernel> put_fd + 0x0032 <kernel> common_close + 0x004c <kernel> _user_close + 0x0014 <kernel> syscall_dispatcher...

This happened on a freshly initialized and installed Haiku partition. The next time I booted, when I synced after taking a screen shot, the sync command didn't return on the command line. The system was like under heavy load. I could still hit F12 to enter KDL and rebooted from there. On the next boot, the partition was toast again (Panic: BFS!... co... eventually Panic: No boot device found.), but booting into R5 fixed it.

Change History (3)

comment:1 by axeld, 14 years ago

Status: newclosed

comment:2 by axeld, 14 years ago

* This bug has been marked as a duplicate of #77 *

comment:3 by axeld, 14 years ago

Resolution: duplicate
Note: See TracTickets for help on using tickets.