Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#77 closed bug (fixed)

unhandled page fault while trying to sync

Reported by: stippi Owned by: axeld
Priority: blocker Milestone: R1
Component: System/Kernel Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

  • set a background image for the current workspace using Backgrounds, noticed

that Tracker didn't pick it up

  • quitted Tracker through the all-modifiers+q shortcut
  • Tracker didn't quit fully, tried to kill it
  • that didn't work so I synced in the Terminal and rebooted by using the KDL

since Tracker didn't quit and the normal shutdown would not proceed

  • on next boot, I relaunched Backgrounds... the image was not remembered, I

reset it, Tracker didn't pick it up again

  • when trying to sync... the system KDLd:

PANIC vm_page_fault: unhandled page fault in kernel space at 0xc, ip 0x80050351 sc: <kernel> ChunkIndex_11block_rangeP11block_cachePv + 0x000d <kernel> Free_11block_rangeP11block_cachePv + 0x001d <kernel> Free_11block_cachePv + 0x002a <kernel> cache_end_transaction + 0x00f0

<bfs> _WriteTransactionToLog7Journal + 0x070f <bfs> FlushLogAndBlocks7Journal + 0x010f <bfs> Sync6Volume + 0x0018 <bfs> bfs_syncFPv + 0x0016

<kernel> fs_syncF1 + 0x004d <kernel> _kern_sync + 0x001d <kernel> _user_sync + 0x000b <kernel> syscall_dispatcher

Change History (17)

comment:1 by axeld, 14 years ago

With what revision was this bug experienced? Message4 or the still current one?

comment:2 by stippi, 14 years ago

I didn't use Message4 when I saw this. While I have switched to Message4 meanwhile to test some other things, I have not yet tried to set a background image again. But I didn't really think that the attribute thing had anything to do with it. Or does it?

comment:3 by axeld, 14 years ago

Do you remember the revision? Was it newer than from 2 days ago?

comment:4 by stippi, 14 years ago

Revision from this morning...15734 most likely. :-)

comment:5 by axeld, 14 years ago

Status: newassigned

comment:6 by axeld, 14 years ago

Thanks, I just managed to reproduce it once.

comment:7 by axeld, 14 years ago

Should be fixed with hrev15749. Can you still reproduce this bug in any way?

comment:8 by axeld, 14 years ago

Status: assignedclosed

comment:9 by axeld, 14 years ago

Resolution: fixed

comment:10 by stippi, 14 years ago

Yes, I just managed to reproduce it again (r 15758), started Backgrounds as the first thing, configured an image, quit Backgrounds, synced - bam! Same stack crawl.

comment:11 by stippi, 14 years ago

Resolution: fixed

comment:12 by stippi, 14 years ago

Status: closedreopened

comment:13 by stippi, 14 years ago

Forgot to mention that my Haiku partition is now toast (Panic: BFS!... until Panic: Can't find boot device). Maybe it was corrupted before... too late to find out. Now I have to initialize it anyways.

comment:14 by stippi, 14 years ago

More insight through the additional debugging info:

PANIC: no range for address 0xa00fb00

... <kernel> Free_11block_cachePv <kernel> cache_end_transaction <bfs> _WriteTransactionToLog <bfs> FlushLogAndBlocks ...

eax: 0x40 ebx: 0x286980 ecx: 0x1 edx: 0x1 esi: 0x7ffef534 edi: 0x2031e3 ebp: 0x7ffe6f4c esp: 0x83563fdc

Hope this helps, -Stephan

comment:15 by axeld, 14 years ago

Resolution: fixed

comment:16 by axeld, 14 years ago

Status: reopenedclosed

comment:17 by axeld, 14 years ago

* Bug 78 has been marked as a duplicate of this bug. *

Note: See TracTickets for help on using tickets.