Opened 8 years ago

Closed 5 months ago

#7864 closed bug (fixed)

[kernel] PANIC: _mutext_lock (): double lock of 0x8019b348 by thread 697157

Reported by: diver Owned by: nobody
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by diver)

This is hrev42467 , gcc2hybrid.

I was trying to reproduce #6673 by running many instances of:

for i in `seq 1 10000`; do mimeset -apps -f /system/apps/*; done

While executing it Haiku was almost unusable, so I left it in this state for some time. Several minutes layer kernel crashed with this panic message.

Attachments (2)

IMG_0009.JPG (1.7 MB) - added by diver 8 years ago.
IMG_0011.JPG (1.1 MB) - added by diver 8 years ago.

Change History (7)

Changed 8 years ago by diver

Attachment: IMG_0009.JPG added

Changed 8 years ago by diver

Attachment: IMG_0011.JPG added

comment:1 Changed 8 years ago by bonefish

Apparently a NULL-pointer is dereferenced in vm_cache_acquire_locked_page_cache(). I don't see how that can happen, though.

comment:2 Changed 2 years ago by axeld

Owner: changed from axeld to nobody
Status: newassigned

comment:3 Changed 5 months ago by waddlesplash

Still reproducible?

comment:4 Changed 5 months ago by diver

Description: modified (diff)

comment:5 Changed 5 months ago by diver

Resolution: fixed
Status: assignedclosed

Can't reproduce on 64bit nightly. Assuming fixed.

Note: See TracTickets for help on using tickets.