Opened 8 years ago

Closed 2 years ago

#7865 closed bug (duplicate)

kernel panic when running cmake (not every time)

Reported by: myob Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: kernel panic vnode Cc:
Blocked By: #5262 Blocking:
Has a Patch: no Platform: All

Description

I'm getting a kernel panic when running cmake on CorsixTH (http://code.google.com/p/corsix-th/), not every single time however. Only when a file relating to cmake has been modified, e.g. the linker list or similar.

Panic is "vnode already exists (node = 0x00c24050, vnode->node = 0x00000000

Attached is a screen-photo

Using SVN hrev42445

Attachments (1)

23072011069.jpg (1.9 MB) - added by myob 8 years ago.

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by myob

Attachment: 23072011069.jpg added

comment:1 Changed 8 years ago by axeld

Does checkfs detect any errors?

comment:2 Changed 8 years ago by myob

checkfs -c /boot

268734 nodes checked, 
0 blocks not already allocated, 
0 blocks already set, 
26779 blocks could be freed

doesn't look that odd?

Last edited 8 years ago by axeld (previous) (diff)

comment:3 Changed 8 years ago by axeld

No, not at all; blocks that can be freed usually means that a file had been deleted, but its space could not be freed during the runtime because of a kernel crash or an unexpected power loss (it's a BFS shortcoming).

comment:4 Changed 4 years ago by pulkomandy

Not reproductible anymore, cmake runs fine and can build Corsix-TH without problems now. Does it still happen for you?

comment:5 Changed 2 years ago by pulkomandy

Blocked By: 5262 added
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.