Opened 8 years ago

Last modified 4 years ago

#7895 reopened bug

[app_server] crashes in DefaultDecorator::_ResizeBy ()

Reported by: diver Owned by: czeidler
Priority: normal Milestone: R1
Component: Add-Ons/Decorators/Default Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

This is hrev42540, gcc2hybrid.

app_server crashed after stacking Terminal+Tracker+MediaPlayer, entering and leaving fullscreen mode in Terminal and closing MediaPlayer from Deskbar.

Attachments (2)

app_server.png (20.6 KB) - added by diver 8 years ago.
SwitchToMP.png (338.7 KB) - added by Ziusudra 6 years ago.
Switched to MediaPlayer after having switched to Tracker

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by diver

Attachment: app_server.png added

comment:1 Changed 8 years ago by czeidler

Resolution: fixed
Status: newclosed

Fixed in hrev42548. Thanks!

comment:2 Changed 6 years ago by Ziusudra

Resolution: fixed
Status: closedreopened

I can reproduce this, or something very like it, on r1a4 and hrev44928.

After telling terminal to go fullscreen, it detaches from the stack just fine. The stack however now only has one window tab with the MediaPlayer title. The Tracker window still appears in the Deskbar list and can be switched to but the window tab retains the MediaPlayer title. Trying to close either window with either the close button or Deskbar causes a segfault. As does trying to switch to MediaPlayer.

(I'm running on hardware and I can't find my camera to take a picture of the backtrace.)

Edit: Forgot to mention that I cannot reproduce #7894 or #7896.

Last edited 6 years ago by Ziusudra (previous) (diff)

Changed 6 years ago by Ziusudra

Attachment: SwitchToMP.png added

Switched to MediaPlayer after having switched to Tracker

comment:3 Changed 4 years ago by luroh

Milestone: R1Unscheduled

Moving S&T related tickets out of R1 milestone (Prop #16).

comment:4 Changed 4 years ago by luroh

Milestone: UnscheduledR1

Moving S&T related tickets back into R1 milestone as S&T is in fact now the default. My apologies.

Note: See TracTickets for help on using tickets.