Opened 8 years ago

Closed 6 years ago

#7914 closed bug (fixed)

[Applications/Vision] Vision settings reset on Haiku upgrade

Reported by: deejam Owned by: anevilyak
Priority: normal Milestone: R1
Component: Applications Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

The settings for Vision is reset after each upgrade of Haiku. Vision is a 3rd party application, so I don't know if this can be fixed by the Haiku project by re-packaging Vision (or whatever is done with the source).

hrev42624 GCC2Hybrid

How to reproduce

  • Change some settings in Vision (for example the Preferred Nicks.
  • Upgrade Haiku
  • The settings is now reset to the default.

Attachments (1)

vision-default-settings.png (21.1 KB) - added by deejam 8 years ago.

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by deejam

Attachment: vision-default-settings.png added

comment:1 Changed 8 years ago by scottmc

Owner: changed from nobody to anevilyak
Status: newassigned

comment:2 Changed 8 years ago by anevilyak

The problem is that the upgrade currently just unzips all the packages. Since the Vision package currently contains the aforementioned default settings file in order to get people started, that results in the user's settings file being overwritten by the one from the zip. I don't really see a way around that with the current installation method, short of splitting the settings into a separate package.

comment:3 Changed 8 years ago by scottmc

What about giving the default settings a different filename and then have Vision only use those settings if the normal settings file is not present?

comment:4 Changed 8 years ago by axeld

A relatively simple solution would be to let Vision differentiate between user and common settings; the zip would install the settings in /boot/common/settings, and Vision would by default store it in /boot/home/config/settings.

comment:5 Changed 6 years ago by anevilyak

Resolution: fixed
Status: assignedclosed

This one should no longer be an issue, Vision now keeps a separate InitialSettings file in its app dir that's used as a template if the config/settings variant doesn't yet exist.

Note: See TracTickets for help on using tickets.