Opened 8 years ago

Closed 8 years ago

#7925 closed bug (duplicate)

[Installer] Window title not localized when booting from CD

Reported by: deejam Owned by: korli
Priority: normal Milestone: R1
Component: Applications/Installer Version: R1/Development
Keywords: Cc:
Blocked By: #7552 Blocking:
Has a Patch: no Platform: All

Description

The Installer window is not localized when booting from CD. If started from an existing system (from Deskbar), it will be localized.

hrev42624 GCC2Hybrid

If Installer is launched from the CD, the window title is not localized.

If the Installer is launched from an already installed system (Deskbar), it is localized.

Attachments (2)

installer_missing_title_localization.png (11.7 KB) - added by deejam 8 years ago.
installer_with_title_localization.png (9.4 KB) - added by deejam 8 years ago.

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by deejam

Changed 8 years ago by deejam

comment:1 Changed 8 years ago by axeld

That's probably because you later enabled translating application names in the preferences. Since that is not the default, the window titles (which is just the application name in this and most cases) will not be translated.

Please confirm, in which case this would be invalid, or merely an enhancement request to alter the default behaviour.

comment:2 in reply to:  1 Changed 8 years ago by deejam

Replying to axeld:

That's probably because you later enabled translating application names in the preferences. Since that is not the default, the window titles (which is just the application name in this and most cases) will not be translated.

Please confirm, in which case this would be invalid, or merely an enhancement request to alter the default behaviour.

You are correct. It is caused by that the fact that the title is translated by Jonas Tracker and Deskbar functionality, and should therefor be an enhancement ticket about enabling it by default. I have already created a ticket for that, so please close this as a duplicate of that ticket (#7552).

comment:3 Changed 8 years ago by axeld

Blocked By: 7552 added
Resolution: duplicate
Status: newclosed

Alright, thanks.

Note: See TracTickets for help on using tickets.