Opened 8 years ago

Closed 8 years ago

#7942 closed bug (duplicate)

Reproducible Crash in WebCore::ResourceHandle::didReceiveAuthenticationChallenge ()

Reported by: mmadia Owned by: leavengood
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: #7438 Blocking:
Has a Patch: no Platform: All

Description

hrev42595-gcc2h + hrev580 of WebPositive.

https://gsoc-wiki.osuosl.org/index.php/2011

The login information was sent to mentors of GSoC 2011.

Shortly after the page finishes loading, WebPositive will crash.

GNU gdb 6.3
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i586-pc-haiku"...(no debugging symbols found)

[tcsetpgrp failed in terminal_inferior: Invalid Argument]
Thread 2800 caused an exception: Segment violation
Reading symbols from /boot/system/runtime_loader...done.
Loaded symbols for /boot/system/runtime_loader
Reading symbols from /boot/apps/WebPositive/lib/libjavascriptcore.so...done.
Loaded symbols for /boot/apps/WebPositive/lib/libjavascriptcore.so
Reading symbols from /boot/apps/WebPositive/lib/libwebcore.so...done.
Loaded symbols for /boot/apps/WebPositive/lib/libwebcore.so
Reading symbols from /boot/apps/WebPositive/lib/libwebkit.so...done.
Loaded symbols for /boot/apps/WebPositive/lib/libwebkit.so
Reading symbols from /boot/common/lib/libcurl.so.4.2.0...done.
Loaded symbols for /boot/common/lib/libcurl.so.4.2.0
Reading symbols from /boot/system/lib/gcc4/libicuuc.so.44...done.
Loaded symbols for /boot/system/lib/gcc4/libicuuc.so.44
Reading symbols from /boot/system/lib/gcc4/libicudata.so.44...
warning: Lowest section in /boot/system/lib/gcc4/libicudata.so.44 is .hash at 00000094
done.
Loaded symbols for /boot/system/lib/gcc4/libicudata.so.44
Reading symbols from /boot/system/lib/gcc4/libpng.so.1.4...done.
Loaded symbols for /boot/system/lib/gcc4/libpng.so.1.4
Reading symbols from /boot/common/lib/libsqlite3.so.0.8.6...done.
Loaded symbols for /boot/common/lib/libsqlite3.so.0.8.6
Reading symbols from /boot/common/lib/libxml2.so.2.7.8...done.
Loaded symbols for /boot/common/lib/libxml2.so.2.7.8
Reading symbols from /boot/system/lib/gcc4/libz.so.1...done.
Loaded symbols for /boot/system/lib/gcc4/libz.so.1
Reading symbols from /boot/system/lib/gcc4/libbe.so...done.
Loaded symbols for /boot/system/lib/gcc4/libbe.so
Reading symbols from /boot/system/lib/gcc4/libbsd.so...done.
Loaded symbols for /boot/system/lib/gcc4/libbsd.so
Reading symbols from /boot/system/lib/gcc4/liblocale.so...done.
Loaded symbols for /boot/system/lib/gcc4/liblocale.so
Reading symbols from /boot/system/lib/gcc4/libnetwork.so...done.
Loaded symbols for /boot/system/lib/gcc4/libnetwork.so
Reading symbols from /boot/system/lib/gcc4/libstdc++.so...done.
Loaded symbols for /boot/system/lib/gcc4/libstdc++.so
Reading symbols from /boot/system/lib/gcc4/libtracker.so...done.
Loaded symbols for /boot/system/lib/gcc4/libtracker.so
Reading symbols from /boot/system/lib/gcc4/libtranslation.so...done.
Loaded symbols for /boot/system/lib/gcc4/libtranslation.so
Reading symbols from /boot/system/lib/gcc4/libroot.so...done.
Loaded symbols for /boot/system/lib/gcc4/libroot.so
Reading symbols from /boot/system/lib/gcc4/libicui18n.so.44...done.
Loaded symbols for /boot/system/lib/gcc4/libicui18n.so.44
Reading symbols from /boot/system/lib/gcc4/libjpeg.so.8.0...done.
Loaded symbols for /boot/system/lib/gcc4/libjpeg.so.8.0
Reading symbols from /boot/system/lib/gcc4/libtextencoding.so...done.
Loaded symbols for /boot/system/lib/gcc4/libtextencoding.so
Reading symbols from /boot/common/lib/libssl.so.1.0.0...done.
Loaded symbols for /boot/common/lib/libssl.so.1.0.0
Reading symbols from /boot/common/lib/libcrypto.so.1.0.0...done.
Loaded symbols for /boot/common/lib/libcrypto.so.1.0.0
Reading symbols from /boot/common/lib/libiconv.so.2.5.0...done.
Loaded symbols for /boot/common/lib/libiconv.so.2.5.0
Reading symbols from /boot/system/lib/gcc4/libicuio.so.44...done.
Loaded symbols for /boot/system/lib/gcc4/libicuio.so.44
Reading symbols from /boot/system/lib/gcc4/libicule.so.44...done.
Loaded symbols for /boot/system/lib/gcc4/libicule.so.44
Reading symbols from /boot/system/lib/gcc4/libiculx.so.44...done.
Loaded symbols for /boot/system/lib/gcc4/libiculx.so.44
Reading symbols from /boot/system/lib/gcc4/libicutu.so.44...done.
Loaded symbols for /boot/system/lib/gcc4/libicutu.so.44
Reading symbols from /boot/system/lib/gcc4/libsupc++.so...done.
Loaded symbols for /boot/system/lib/gcc4/libsupc++.so
Reading symbols from /boot/system/lib/gcc4/libroot-addon-icu.so...done.
Loaded symbols for /boot/system/lib/gcc4/libroot-addon-icu.so
[tcsetpgrp failed in terminal_inferior: Invalid Argument]
[Switching to team /boot/apps/WebPositive/WebPositive (2800) thread WebPositive (2800)]
0x00a6b4b8 in WebCore::ResourceHandle::didReceiveAuthenticationChallenge ()
   from /boot/apps/WebPositive/lib/libwebcore.so
(gdb) bt
#0  0x00a6b4b8 in WebCore::ResourceHandle::didReceiveAuthenticationChallenge ()
   from /boot/apps/WebPositive/lib/libwebcore.so
#1  0x00a72d33 in _ZN7WebCoreL24handleHTTPAuthenticationEPNS_14ResourceHandleE ()
   from /boot/apps/WebPositive/lib/libwebcore.so
#2  0x00a7376d in WebCore::ResourceHandleManager::downloadTimerCallback ()
   from /boot/apps/WebPositive/lib/libwebcore.so
#3  0x00a738d0 in WebCore::Timer<WebCore::ResourceHandleManager>::fired ()
   from /boot/apps/WebPositive/lib/libwebcore.so
#4  0x00a1070b in WebCore::ThreadTimers::sharedTimerFiredInternal ()
   from /boot/apps/WebPositive/lib/libwebcore.so
#5  0x00a10769 in WebCore::ThreadTimers::sharedTimerFired ()
   from /boot/apps/WebPositive/lib/libwebcore.so
#6  0x00a4d188 in WebCore::SharedTimerHaiku::MessageReceived ()
   from /boot/apps/WebPositive/lib/libwebcore.so
#7  0x027ae9ca in BLooper::DispatchMessage () from /boot/system/lib/gcc4/libbe.so
#8  0x027a6de5 in BApplication::DispatchMessage ()
   from /boot/system/lib/gcc4/libbe.so
#9  0x027afc4e in BLooper::task_looper () from /boot/system/lib/gcc4/libbe.so
#10 0x027a61f8 in BApplication::Run () from /boot/system/lib/gcc4/libbe.so
#11 0x0023b233 in main ()
(gdb) 

Change History (2)

comment:1 by phoudoin, 8 years ago

Sounds like a duplicate of #7438.

comment:2 by mmadia, 8 years ago

Blocked By: 7438 added
Resolution: duplicate
Status: newclosed

Indeed it does sound like a duplicate.

Note: See TracTickets for help on using tickets.