Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#7966 closed bug (fixed)

WebPositive UI inconsistant with Haiku.

Reported by: bbjimmy Owned by: leavengood
Priority: normal Milestone: R1
Component: Applications/WebPositive Version: R1/Development
Keywords: Cc:
Blocked By: #8666 Blocking:
Has a Patch: no Platform: All

Description

The resize bytton should not go to full screen mode, but rather to leve the tab at the top of the scteen so that the user can still access the leaf menu when the deskbar is in its default position. This should toggle between this size and any smaller size the user has changed the window to. This is how all apps on Haiku should work. Pe , StyledEdit, Terminal etc all use this scheme for resizing.

Change History (6)

comment:1 Changed 8 years ago by axeld

It's not per se how this button should work. The button is documented to switch between two useful sizes. In Tracker, it will resize the window to its ideal size (and back to what it was before). And for example, in MediaPlayer it enters full screen (same as with ShowImage, but there was a discussion on the list a few weeks ago about changing that again).

Since WebPositive has a tabbed interface, I am not sure there is an ideal size of the window (as that would have to be large enough to make all scroll bars for all tabs go away). Personally, I find switching to full screen much more useful for it in this case - as in MediaPlayer, although I'm sure that's debatable.

comment:2 Changed 8 years ago by Disreali

Having the resize button make Web+ go to fullscreen is _not useful_ and is extremely annoying. There is another mechinism to have the app go fullscreen, ALT+ENTER and F11. The current behaviour forces the user to spend much more time and effort to get the window in the best opproximation of the prior maximize behaviour.

comment:3 Changed 7 years ago by Disreali

ticket:8666 is a duplicate.

comment:4 Changed 7 years ago by mmadia

Blocked By: 8666 added

(In #8666) Closing as duplicate of #7966

comment:5 Changed 7 years ago by leavengood

Resolution: fixed
Status: newclosed

Fixed in hrev44431.

comment:6 Changed 7 years ago by Disreali

Thanks.

Note: See TracTickets for help on using tickets.