Opened 8 years ago

Closed 5 years ago

#7968 closed bug (fixed)

CDDA volume path oddity (possibly display issue)

Reported by: myob Owned by: bga
Priority: normal Milestone: R1
Component: File Systems/cdda Version: R1/Development
Keywords: Cc: degea@…
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

hrev42445 (but I've looked to see if a change that might affect it has been done since and can't see anything)

Insert a CD, FreeDB data for it comes down sucesfully and the name is shown correctly in Disks and in the title bar of the Tracker window when I open the volume created

However the path, as shown in the title bar and confirmed from the CLI contains untypeable characters

I've not seen this with any other CD.

Attachments (5)

starsofcctv.png (28.9 KB ) - added by myob 8 years ago.
screenshot
Works for me r42445.png (42.8 KB ) - added by jscipione 8 years ago.
I compiled Haiku hrev42445 and mounted the Stars of CCTV album and it came up fine for me, so I still have no idea what is causing this for you but it must be intermittant.
a50a910borig (3.6 KB ) - added by myob 8 years ago.
original cdda info file
a50a910b (3.3 KB ) - added by myob 8 years ago.
second cdda info file (displays correctly)
CDDA_uppercase_string_1.diff (3.5 KB ) - added by jscipione 8 years ago.
This is a patch that redoes the CDDA file system str_uppercase to look out for words that don't get uppercased. Since the bug seems to get triggered on the 'O' in 'Of' this code is a bit safer, no idea if it will fix this issue though…

Download all attachments as: .zip

Change History (13)

by myob, 8 years ago

Attachment: starsofcctv.png added

screenshot

comment:1 by jscipione, 8 years ago

I have narrowed down the CDDB database file for this album to either:

http://www.freedb.org/freedb/folk/a50a910b

or

http://www.freedb.org/freedb/newage/9b0aa60b

I examined the files of each file and they are both plain text with \n line endings and no discernible non-ascii characters in them. So I am pretty sure that the input file used here is valid.

by jscipione, 8 years ago

Attachment: Works for me r42445.png added

I compiled Haiku hrev42445 and mounted the Stars of CCTV album and it came up fine for me, so I still have no idea what is causing this for you but it must be intermittant.

comment:2 by myob, 8 years ago

Its a501910.

I deleted the CDDA info file to see if that had any affect, and it does. Comes back clear this time.

I'm attaching the old and new files to see if they're likely to be any help.

by myob, 8 years ago

Attachment: a50a910borig added

original cdda info file

by myob, 8 years ago

Attachment: a50a910b added

second cdda info file (displays correctly)

by jscipione, 8 years ago

This is a patch that redoes the CDDA file system str_uppercase to look out for words that don't get uppercased. Since the bug seems to get triggered on the 'O' in 'Of' this code is a bit safer, no idea if it will fix this issue though...

comment:3 by jscipione, 8 years ago

Has a Patch: set

comment:4 by axeld, 8 years ago

This won't fix anything, and is definitely not safer (the code is just a magnitude more complicated). Furthermore, I think this is overkill, and shouldn't end up in the tree.

I suspect some kind of memory corruption inside CDDA, but it's certainly not buried in this function. There is another open ticket that leads the system to KDL sometimes with CDDA; I would assume those are related.

comment:5 by ttcoder, 8 years ago

Cc: degea@… added

Will be on the lookout for such ticket(s) in a few days as I'll start working with dsuden on a (recoverable) KDL that occurs when ripping/Encoding CDDA's into mp3. Might be able to provide additional crash info ..etc.

comment:6 by tqh, 8 years ago

Has a Patch: unset

comment:7 by tqh, 8 years ago

Marking patch obsolete on the info in comment:4. Improved patch would be needed.

comment:8 by waddlesplash, 5 years ago

Resolution: fixed
Status: newclosed

Probably fixed in hrev48946.

Note: See TracTickets for help on using tickets.