Opened 8 years ago

Last modified 5 years ago

#8002 reopened bug

USB devices not working on SB600 - device timeouts.

Reported by: xsive Owned by: nobody
Priority: normal Milestone: R1
Component: Drivers/USB/OHCI Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I've finally got haiku booking with a latest nightly thanks for sorting the memory issue in bootloader.

However now my usb keyboard and mouse aren't working. I'm on a SB600 chipset and have disabled ACPI but to no avail. Syslog attached.

Pasted this bit as I assume this is where the error starts, keeps repeating:

usb error control pipe 32: timeout waiting for queued request to complete usb error ohci -1

Attachments (2)

SYSLOG00.TXT (65.6 KB ) - added by xsive 8 years ago.
SYSLOG01.TXT (78.5 KB ) - added by xsive 8 years ago.
no safe mode options

Download all attachments as: .zip

Change History (12)

by xsive, 8 years ago

Attachment: SYSLOG00.TXT added

comment:2 by diver, 8 years ago

Blocked By: 5551 added
Resolution: duplicate
Status: newclosed
Version: R1/alpha3R1/Development

comment:3 by mmlr, 8 years ago

Blocked By: 5551 removed
Resolution: duplicate
Status: closedreopened

This looks like a more generic interrupt issue, as it affects both OHCI and EHCI. Does it also affect networking, i.e. does networking work? You mention that you tried without ACPI, can you also post a log with ACPI on to check the interrupt routing info it provides?

by xsive, 8 years ago

Attachment: SYSLOG01.TXT added

no safe mode options

comment:4 by xsive, 8 years ago

This is the syslog with no safe mode options, does this part help any?

error: 0x00080248 usb error control pipe 31: timeout waiting for queued request to complete usb error ehci -1: qtd (0x0381ac00)

I can't try network etc...as I dont have a ps2 mouse or anything I can't get past the welcome screen to test

comment:5 by xsive, 8 years ago

Hmmm if I plug my usb mouse using an adaptor into the PS2 port now the USB keyboard is working fine but no mouse... I'll try to upload syslog

comment:6 by xsive, 8 years ago

Don't know if you want to close this tickets as the SB600 issue isn't applicable to me anymore as I've changed to an intel system

comment:7 by exidux, 5 years ago

Connecting a trust drawing tablet produces the following timeouts again and again. A snippet filered from the log ;

KERN: usb hub 7: port 0: new device connected
KERN: usb error control pipe 44: timeout waiting for queued request to complete
KERN: usb error uhci -1: error while setting device address

My system however is not an sb600.

Last edited 5 years ago by exidux (previous) (diff)

comment:8 by exidux, 5 years ago

Summary: USB devices not working on SB600USB devices not working on SB600 - device timeouts.

comment:9 by diver, 5 years ago

Component: - GeneralDrivers/USB

comment:10 by waddlesplash, 5 years ago

Component: Drivers/USBDrivers/USB/OHCI

Filtering OHCI tickets from Drivers/USB to Drivers/USB/OHCI.

Note: See TracTickets for help on using tickets.