Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#8011 closed enhancement (fixed)

Radeon HD 4550 display problem

Reported by: lalit Owned by: kallisti5
Priority: normal Milestone: R1
Component: Drivers/Graphics/radeon_hd Version: R1/Development
Keywords: Radeon hd 4550 Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

I just tried to install Haiku to Dell 5150c desktop. The configuration is Pentium - D 3ghz, 4gb ram, Radeon HD 4550 graphics with hdmi, it also got on board spdif sound output. While installing it took longer time to start, stuck at the fourth icon with haiku leaf. Then it install successfully installed.

I am getting 640 x 400 resolution and no sound. I have got viewsonic full hd display. While changing the resolution it is giving error and there is no resultion for 1080p full hd.

I am attaching the sys log file.

Attachments (4)

syslog (508.7 KB) - added by lalit 8 years ago.
syslog.2 (508.7 KB) - added by lalit 8 years ago.
sound driver.png (50.9 KB) - added by lalit 8 years ago.
current sound devices detected by windows
syslog.3 (419.8 KB) - added by lalit 8 years ago.
hrev42889 log

Download all attachments as: .zip

Change History (23)

Changed 8 years ago by lalit

Attachment: syslog added

Changed 8 years ago by lalit

Attachment: syslog.2 added

comment:1 Changed 8 years ago by ttcoder

I am getting 640 x 400

The devs will confirm/infirm, but IIRC the native Radeon driver is in beta and not part of Haiku builds, even in recent nightlies.

From the syslog, it seems Haiku falls back to the VESA driver and 1400x1050x32 resolution, and repeatedly fails (?) at it with this message, oddly sent a ton of times to the syslog:

KERN: vesa: vbe_get_mode_info(326): vm86 failed
1632	KERN: vesa: vesa_set_display_mode(): cannot get mode info

Not sure if I'm interpreting correctly.

Recent Haiku nightlies (see Webpositive/Bookmarks) might improve VESA, there's been several commits in the last few months.

and no sound

There's no sign of activity for "ati HD audio" in the syslog, but the HDA driver seems good, apart from an early initialization warning/error.. Are you speakers connected to the HDA jack or to the ati radeon audio jack? Does the HDA audio show up in the Media panel ?

Last edited 8 years ago by ttcoder (previous) (diff)

comment:2 Changed 8 years ago by lalit

I am getting only 640x400 resolution most of the time. Sometime it gives 800x600 and also couple of times I got 1400x1050. I can't change the resolutions, it gives me error. Is it possible to set the vesa driver please? I am not familiar to the nightly builds, do I have to reinstall Haiku or will I get a patch for this?

Regarding sound, I can see the HD sound driver installed. But not getting any sound through headphone, speaker or even spdif. Only thing I have not tested is ati hdmi sound port.

Find the attached pic of current sound devices detected by windows on the same machine.

Changed 8 years ago by lalit

Attachment: sound driver.png added

current sound devices detected by windows

comment:3 Changed 8 years ago by modeenf

Pleas make a new ticket for sound problems :)

comment:4 Changed 8 years ago by modeenf

Component: Audio & VideoDrivers/Graphics/radeon_hd
Owner: changed from nobody to kallisti5

comment:5 Changed 8 years ago by modeenf

Owner: changed from kallisti5 to nobody
Status: newassigned

hm why did it change from nobody to kallisti5? I only change it to right component..

comment:6 Changed 8 years ago by ttcoder

I'm not 100% positive but I think the VESA driver is active, not the RadeonHD one; and the "basic" Radeon driver cannot handle the card:

KERN: Radeon - init_hardware: Version: 5.1.6.0
KERN: Radeon - Radeon_CardDetect: no supported devices found

For upgrading to a nightly, it takes just a few minutes once the RAW image is downloaded, using a simple (but oddly, not publicized very much) process:

  • download the latest Raw (not anyboot nor CD) nightly, and uncompress it
  • double-click the uncompressed .image file, a new virtual partition will appear on your desktop, called simply "Haiku" (hence it's important that your real/physical harddrive partition not be named simply "Haiku", otherwise it entails confusion)
  • double-click the "Haiku" virtual drive, and copy its "system" and "common" folders to your real Haiku partition.. You'll probably want to move those away first (or rename them) rather than clobber/overwrite them.. That way, you may revert back the upgrade if needed.
  • wait for the hard-drive to completely finish writing (BFS sync) and then reboot without further modifications nor launching anything.. Some ugprade paths don't like having one version of Haiku loaded in memory and another on the HDD..

That's about it. The above will copy the default syslog and swap file from the image though, so a more clean way to do it would be to use Installer (choosing the virtual Haiku drive as source, and another partition as destination) rather than use Tracker to copy files.

Last edited 8 years ago by ttcoder (previous) (diff)

comment:7 Changed 8 years ago by kallisti5

Type: bugenhancement
Version: R1/alpha3R1/Development

It changed to kallisti5 because I'm working on the Radeon HD driver :)

The Radeon driver handles older Radeon cards. The newer generation Radeon HD cards need a new driver. This new Radeon HD driver isn't in the Haiku nightly builds at the moment because mode switching is not yet complete (so you will just see a blank screen, no video, etc)

The state of the Radeon HD video driver is close, however for now the fallback VESA driver is your only option.

Radeon HD driver development is *very* active and you can see all the code changes to support it by going here: http://dev.haiku-os.org/search?q=kallisti5&noquickjump=1&changeset=on

Hopefully once I have mode switching done Radeon HD will support huge displays, multiple monitors, hdmi, etc.

comment:8 Changed 8 years ago by modeenf

kallisti5 : It's realy nice to follow your progress :) my next laptop will have a radeon HD :)

comment:9 Changed 8 years ago by kallisti5

Owner: changed from nobody to kallisti5

comment:10 Changed 8 years ago by lalit

kallisti5, it sounds great to me. So what is your advice, should I wait for the driver or can I try the nightly builds as advised by ttcoder. Is there any way to get a better resolution than 640x400, till the driver is ready?

comment:11 Changed 8 years ago by kallisti5

Try the latest nightly post hrev42888, you have a pretty good chance of it working perfectly or of a app_server crash :)

comment:12 Changed 8 years ago by lalit

Kallisti5, I tried hrev42889. After the booting window, I am getting a blank screen. No error nothing. Find the attached syslog for more details.

Changed 8 years ago by lalit

Attachment: syslog.3 added

hrev42889 log

comment:13 Changed 8 years ago by ttcoder

Looks like radeon_get_frame_buffer_config is the last function called..

comment:14 Changed 8 years ago by kallisti5

Two potential issues here:

  • Your card has a DIG encoder:
    • KERN: radeon_hd: encoder_mode_set: TODO for DIG encoder setup
    • Dig encoder support isn't done yet.
  • Your card is a 4550
    • I've been seeing hrev700+ cards show a black / white / blue screen. Not sure of the cause just yet but working on it.

I'll let you know when I have a potential solution in place.

Thanks!

comment:15 Changed 8 years ago by phoudoin

I tried too this sunday with my Radeon HD 4870.
Got the white screen and this error in syslog:

KERN: radeon_hd: radeon_dpms_set: ON
KERN: radeon_hd: display_crtc_lock
KERN: radeon_hd: display_crtc_power
KERN: radeon_hd: display_crtc_memreq
KERN: radeon_hd: display_crtc_blank
KERN: radeon_hd: atom_op_jump: DANGER! AtomBIOS stuck in loop for more then 128 jumps... abort!
KERN: radeon_hd: AtomBios parser was aborted executing (0xD40F)
KERN: radeon_hd: display_crtc_lock

That was a hrev42898 gcc4hybrid, full build (jam -qa @disk).
Hope this help.

Last edited 8 years ago by phoudoin (previous) (diff)

comment:16 Changed 8 years ago by kallisti5

try again. 4xxx should be pretty stable now :)

comment:17 in reply to:  16 Changed 8 years ago by phoudoin

Replying to kallisti5:

try again. 4xxx should be pretty stable now :)

I confirm that: my 4870 works fine now, and having Haiku in full HD native resolution is a bless! Thanks for all your hard work to make this happens.

comment:18 Changed 8 years ago by kallisti5

Resolution: fixed
Status: assignedclosed

comment:19 Changed 8 years ago by lalit

It works for me as well. But I can use only the svga output. DVI output not working. HDMI not tested.

Anyway Thanks Kallisti, great effort. You are the king of kings. You are the great Alexander!!

Note: See TracTickets for help on using tickets.