Opened 8 years ago

Last modified 9 months ago

#8020 assigned bug

Wireless Connection problem with Intel 3945 Wireless Card

Reported by: jackburton Owned by: nobody
Priority: normal Milestone: R1
Component: Drivers/Network/iprowifi3945 Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by jackburton)

I have a wpa2 protected wireless network at home, and a laptop with an Intel 3945 wireless card. Connecting to the wireless network often fails, and I have to try many times. From the logs I see it tries to connect to various non-hidden wpa2 networks I have in the neighborhood. Sometimes it connects to my network, but it happens only once in a while.

From the net_server logs, it seems it associates to the network, but then timeouts while authenticating.

Attachments (3)

net_server.log (3.8 KB) - added by jackburton 8 years ago.
net server logs for the join try
syslog.log (7.3 KB) - added by jackburton 8 years ago.
wireless_log.txt (11.1 KB) - added by jackburton 5 years ago.
One more log

Download all attachments as: .zip

Change History (14)

Changed 8 years ago by jackburton

Attachment: net_server.log added

net server logs for the join try

Changed 8 years ago by jackburton

Attachment: syslog.log added

comment:1 Changed 8 years ago by jackburton

Addendum: looks like it works a bit better with static configuration (IOW: no DHCP).

comment:2 Changed 7 years ago by phoudoin

I wonder if, as in Haiku ap scan is done by drivers and net_server, wpa_supplicant's ap_scan option should not be disabled (set to 0 or, maybe, 2 - see ap_scan option documentation) instead...

comment:3 Changed 7 years ago by tqh

Have you tested recent revisions? It has been working much better for me since hrev44350, although I don't have a hidden network.

comment:4 Changed 7 years ago by jackburton

Resolution: fixed
Status: newclosed

Works correctly now

comment:5 Changed 7 years ago by jackburton

Resolution: fixed
Status: closedreopened

No, not really. Worked the first time, rebooted, worked also the second time (joining by hand, with ifconfig join.... Then, left the WLAN, tried to join again (without rebooting) and didn't work. Tried multiple times, also ifconfig down/up, but no luck.

comment:6 Changed 5 years ago by jackburton

Component: Network & Internet/WirelessDrivers/Network/iprowifi3945
Description: modified (diff)

comment:7 Changed 5 years ago by jackburton

Could be related to the intel 3945 driver/firmware. It was working correctly in Ubuntu until version 12.04. Now I updated to Ubuntu 12.10 and I have the same issues that I see under Haiku (I have to try multiple times to be able to get a connection).

comment:8 Changed 5 years ago by jackburton

Summary: Connecting to wpa2 wireless network often doesn't workWireless Connection problem with Intel 3945 Wireless Card

Changed 5 years ago by jackburton

Attachment: wireless_log.txt added

One more log

comment:9 Changed 2 years ago by axeld

Owner: changed from axeld to nobody
Status: reopenedassigned

comment:10 Changed 10 months ago by waddlesplash

The iprowifi3945 driver was synced with FreeBSD 11.1 in hrev52043; please retest.

comment:11 Changed 10 months ago by cocobean

@jackburton - I worked with waddlesplash to confirm that the current wpi driver works perfectly in FreeBSD 11.2-STABLE (same wpi driver used for FreeBSD 11.1-RELEASE) w/ wpa_supplicant v2.5. Researching current issue in #14235 and #14260.

Last edited 9 months ago by cocobean (previous) (diff)
Note: See TracTickets for help on using tickets.