Opened 3 months ago

Closed 2 months ago

#14235 closed bug (fixed)

KDL/VM pagefault during boot process

Reported by: cocobean Owned by: nobody
Priority: normal Milestone: Unscheduled
Component: Drivers/Network/iprowifi3945 Version: R1/Development
Keywords: Cc: korli
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Tested with hrev52044 x86 and HP laptop. During the boot process between after boot splash screen red rocket icon-> desktop screen, I get a consistent KDL with VM pagefault (versus a previous 'no rate table for channel' error when using previous driver on hrev52039 (see #13364)).

Attachments (14)

P_20180629_054308[1].jpg (2.2 MB) - added by cocobean 3 months ago.
KDL event on HP laptop w/hrev52044 x86
P_20180629_071032[1].jpg (1.6 MB) - added by cocobean 3 months ago.
KDL Syslog output
syslog (103.4 KB) - added by cocobean 3 months ago.
Clean boot syslog
hrev52031_syslog (229.2 KB) - added by cocobean 3 months ago.
Syslog from hrev52031 x86
P_20180629_082809[1].jpg (4.1 MB) - added by cocobean 3 months ago.
KDL Syslog output from hrev52031 x86
P_20180702_155934[1].jpg (2.5 MB) - added by cocobean 3 months ago.
KDL Syslog output from hrev52031 x86 w/20180702 wifi driver
P_20180702_171339[1].jpg (4.1 MB) - added by cocobean 3 months ago.
KDL Syslog output from hrev52031 x86 w/20180702 wifi driver (-2)
P_20180702_183021[1].jpg (2.2 MB) - added by cocobean 3 months ago.
KDL Syslog output from hrev52056 x86 w/20180702 wifi driver (-3)
P_20180702_193307[1].jpg (4.7 MB) - added by cocobean 3 months ago.
KDL Syslog output from hrev52056 x86 w/20180702 wifi driver (w/BSD firmware check)
P_20180702_200024[1].jpg (2.1 MB) - added by cocobean 3 months ago.
KDL Syslog output from hrev52057 x86 w/20180702 wifi driver (recheck)
haiku_hrevr1alpha4-44702_iprowifi3945-cocobean (3.4 KB) - added by cocobean 3 months ago.
KDL Syslog iprowifi3945 output from Haiku R1/Alpha 4.1 (hrev44702) - reference
P_20180703_100232[1].jpg (4.3 MB) - added by cocobean 3 months ago.
KDL of iprowifi3945 'no rate table for channel' error from Haiku R1/Alpha 4.1 (hrev44702)
P_20180710_175343[1].jpg (2.5 MB) - added by cocobean 2 months ago.
KDL Syslog output from hrev52091 x86 w/20180702 wifi driver
P_20180710_175102[1].jpg (4.3 MB) - added by cocobean 2 months ago.
VM Page fault from hrev52091 x86 w/20180702 wifi driver

Change History (25)

Changed 3 months ago by cocobean

Attachment: P_20180629_054308[1].jpg added

KDL event on HP laptop w/hrev52044 x86

comment:1 Changed 3 months ago by waddlesplash

Can you please try the following:

  1. Ensure you don't have an iprowifi3945 driver in non-packaged.
  2. Blacklist this driver in the bootloader, so you can get to the desktop.
  3. Extract the "haiku" package and copy this driver to your Desktop.
  4. Reboot, with the driver blacklisted via settings file.
  5. Copy the extracted driver to non-packaged to activate it

If you have a driver in non packaged as of step 1, that is very probably the issue.

comment:2 Changed 3 months ago by cocobean

This is from the Live CD only. Can reboot and safe-mode to desktop without issues. VM page fault panic with driver is the only major issue for now.

Changed 3 months ago by cocobean

Attachment: P_20180629_071032[1].jpg added

KDL Syslog output

Changed 3 months ago by cocobean

Attachment: syslog added

Clean boot syslog

Changed 3 months ago by cocobean

Attachment: hrev52031_syslog added

Syslog from hrev52031 x86

Changed 3 months ago by cocobean

Attachment: P_20180629_082809[1].jpg added

KDL Syslog output from hrev52031 x86

comment:3 Changed 3 months ago by waddlesplash

Cc: korli added
bus_dmamem_alloc failed to align memory properly.

That message comes from here: http://xref.plausible.coop/source/xref/haiku/src/libs/compat/freebsd11_network/fbsd_busdma_x86.c#532

korli, do you have any ideas? Otherwise I'll try to investigate myself.

comment:4 Changed 3 months ago by cocobean

Verified wpi driver works on FreeBSD 11.2-STABLE (rev. 335761) w/ wpa_supplicant v2.5 versus Haiku hrev52054 x86.

Last edited 3 months ago by cocobean (previous) (diff)

Changed 3 months ago by cocobean

Attachment: P_20180702_155934[1].jpg added

KDL Syslog output from hrev52031 x86 w/20180702 wifi driver

comment:5 Changed 3 months ago by waddlesplash

I tried removing the first case (use malloc only) in fbsd_busdma_x86 but it doesn't seem to have helped, we still get "failed to align memory properly." Interesting. I suppose I should add some more debug info.

Changed 3 months ago by cocobean

Attachment: P_20180702_171339[1].jpg added

KDL Syslog output from hrev52031 x86 w/20180702 wifi driver (-2)

comment:6 Changed 3 months ago by waddlesplash

... requested 16384, got 0xdf175aa8

(and repetitions)

16384 is 0x4000, which looks to be http://xref.plausible.coop/source/xref/freebsd-11-stable/sys/dev/wpi/if_wpireg.h#44 (WPI_RING_DMA_ALIGN). That is a really weird amount; it looks like no other driver has that kind of requirement. I wonder if our allocator even handles that?

Changed 3 months ago by cocobean

Attachment: P_20180702_183021[1].jpg added

KDL Syslog output from hrev52056 x86 w/20180702 wifi driver (-3)

Changed 3 months ago by cocobean

Attachment: P_20180702_193307[1].jpg added

KDL Syslog output from hrev52056 x86 w/20180702 wifi driver (w/BSD firmware check)

Changed 3 months ago by cocobean

Attachment: P_20180702_200024[1].jpg added

KDL Syslog output from hrev52057 x86 w/20180702 wifi driver (recheck)

comment:7 Changed 3 months ago by cocobean

The current issue is very similar to past issue on iprowifi4965 - Ref #8623. A user reportedly had things working 'somewhat' in hrev51500 (ticket #12482) without the KDL. A few users reported their other WLAN NICs from Atheros/BCM didn't initialize or connect to their NICs as well properly (ref #2998, #5546, and #10729) so this is a similar issue not specific to the iprowifi3945 driver/hardware.

Last edited 3 months ago by cocobean (previous) (diff)

Changed 3 months ago by cocobean

KDL Syslog iprowifi3945 output from Haiku R1/Alpha 4.1 (hrev44702) - reference

Changed 3 months ago by cocobean

Attachment: P_20180703_100232[1].jpg added

KDL of iprowifi3945 'no rate table for channel' error from Haiku R1/Alpha 4.1 (hrev44702)

comment:8 Changed 3 months ago by cocobean

Backtracked. Tested wifi on Haiku R1a2 (hrev36769) and Haiku R1a4.1 (hrev44702).

HaikuR1a4.1 test - I have pseudo IP/gateway info but wpa_supplicant wouldn't initialize properly (errored out) to join network and no wifi networks detected during scan. Can see iprowifi3945 in Network Preferences and get a network menu GUI to select adapters and select DHCP/static or disable modes. Wifi adapter doesn't properly initialize during boot which is needed to work before any user interaction or wireless network detection scan/join.

The original 'no rate table for channel' error happens from Haiku R1a2 hrev36769 to hrev52044 for my laptop - confirming #13364. So, this issue was always there and probably triggered by specific laptop model configurations (if not seen on others).

The current VM_pagefault issue on hrev52044 - hrev52058 is related to a previous issue with the iprowifi4965 driver (#8623) also failing on Haiku R1a4.1. Since this driver is currently working with the newer nightly revisions (hrev52045 and higher), there might be something in the iprowifi4965 driver (or firmware) that was fixed versus iprowifi3945. Worth a shot to review/discuss further.

Last edited 3 months ago by cocobean (previous) (diff)

Changed 2 months ago by cocobean

Attachment: P_20180710_175343[1].jpg added

KDL Syslog output from hrev52091 x86 w/20180702 wifi driver

Changed 2 months ago by cocobean

Attachment: P_20180710_175102[1].jpg added

VM Page fault from hrev52091 x86 w/20180702 wifi driver

comment:9 Changed 2 months ago by waddlesplash

OK, that one should be solved with hrev52092.

comment:10 Changed 2 months ago by cocobean

Confirmed w/hrev52092 x86. Resolved KDL/VM pagefault during boot process issue. Syslog shows 'could not power ON adapter'...'could not read EEPROM' errors. Desktop boots and works fine. Still can use wired Ethernet adapter. Everything else works as usual - no blacklist needed for driver.

Issue resolved.

comment:11 Changed 2 months ago by waddlesplash

Resolution: fixed
Status: newclosed

Hooray!

Please open a new ticket for the "failed to read EEPROM" error.

Note: See TracTickets for help on using tickets.