Opened 8 years ago

Closed 8 years ago

#8038 closed bug (invalid)

Subversion r42887 breaks build with keyboard add-on link failure: file format not recognized

Reported by: Don Quixote Owned by: bonefish
Priority: normal Milestone: R1
Component: Build System Version: R1/Development
Keywords: r42887, input_server, build, link Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

I'm not yet very familiar with Jam. How can I get a more verbose build log?

The problem seems to be that the keyboard add-on is built wrong, as the linker says its file format is not recognized.

I'd love to submit a patch for this myself but I will need some clues as to how to go about it as I'm not yet very familiar with Haiku's codebase.

I kept the serial debug output, but there doesn't seem to be anything in it of interest.

$ jam -q @alpha-raw ... MkDir1 /Bild/Haiku/i686_r42887/objects/haiku/x86/release/add-ons/input_server/devices/keyboard C++ /Bild/Haiku/i686_r42887/objects/haiku/x86/release/add-ons/input_server/devices/keyboard/KeyboardInputDevice.o C++ /Bild/Haiku/i686_r42887/objects/haiku/x86/release/add-ons/input_server/devices/keyboard/Keymap.o C++ /Bild/Haiku/i686_r42887/objects/haiku/x86/release/add-ons/input_server/devices/keyboard/TeamMonitorWindow.o C++ /Bild/Haiku/i686_r42887/objects/haiku/x86/release/add-ons/input_server/devices/keyboard/TeamListItem.o MkDir1 /Bild/Haiku/i686_r42887/objects/haiku/x86/common/add-ons/input_server MkDir1 /Bild/Haiku/i686_r42887/objects/haiku/x86/common/add-ons/input_server/devices MkDir1 /Bild/Haiku/i686_r42887/objects/haiku/x86/common/add-ons/input_server/devices/keyboard ResComp1 /Bild/Haiku/i686_r42887/objects/haiku/x86/common/add-ons/input_server/devices/keyboard/Keyboard.rsrc Link /Bild/Haiku/i686_r42887/objects/haiku/x86/release/add-ons/input_server/devices/keyboard/keyboard /Bild/Haiku/i686_r42887/objects/haiku/x86/release/servers/input/input_server: file not recognized: File format not recognized collect2: ld returned 1 exit status

rm -f "/Bild/Haiku/i686_r42887/objects/haiku/x86/release/add-ons/input_server/devices/keyboard/keyboard" gcc -nostart -Xlinker -soname="keyboard" -nostdlib -Xlinker --no-undefined -o "/Bild/Haiku/i686_r42887/objects/haiku/x86/release/add-ons/input_server/devices/keyboard/keyboard" "/Bild/Haiku/i686_r42887/objects/haiku/x86/release/system/glue/arch/x86/crti.o" "/boot/develop/abi/x86/gcc2/tools/gcc-2.95.3-haiku-100818/lib/gcc-lib/i586-pc-haiku/2.95.3-haiku-100818/crtbegin.o" "/Bild/Haiku/i686_r42887/objects/haiku/x86/release/system/glue/init_term_dyn.o" "/Bild/Haiku/i686_r42887/objects/haiku/x86/release/add-ons/input_server/devices/keyboard/KeyboardInputDevice.o" "/Bild/Haiku/i686_r42887/objects/haiku/x86/release/add-ons/input_server/devices/keyboard/Keymap.o" "/Bild/Haiku/i686_r42887/objects/haiku/x86/release/add-ons/input_server/devices/keyboard/TeamMonitorWindow.o" "/Bild/Haiku/i686_r42887/objects/haiku/x86/release/add-ons/input_server/devices/keyboard/TeamListItem.o" \ "/Bild/Haiku/i686_r42887/objects/haiku/x86/release/servers/input/input_server" "/Bild/Haiku/i686_r42887/objects/haiku/x86/release/kits/libbe.so" "/Bild/Haiku/i686_r42887/objects/haiku/x86/release/kits/shared/libshared.a" "/Bild/Haiku/i686_r42887/objects/haiku/x86/release/kits/locale/liblocale.so" "/Bild/Haiku/i686_r42887/objects/haiku/x86/release/kits/locale/liblocalestub.a" "/Bild/Haiku/i686_r42887/objects/haiku/x86/release/system/libroot/libroot.so" "/boot/develop/abi/x86/gcc2/tools/gcc-2.95.3-haiku-100818/lib/gcc-lib/i586-pc-haiku/2.95.3-haiku-100818/crtend.o" "/Bild/Haiku/i686_r42887/objects/haiku/x86/release/system/glue/arch/x86/crtn.o" \

...failed Link /Bild/Haiku/i686_r42887/objects/haiku/x86/release/add-ons/input_server/devices/keyboard/keyboard ...

BUILD FAILURE: ...failed updating 1 target(s)... ...skipped 2 target(s)... ...updated 12194 target(s)...

Change History (4)

comment:1 Changed 8 years ago by bonefish

/Bild/Haiku/i686_r42887/objects/haiku/x86/release/servers/input/input_server:
 file not recognized: File format not recognized

Looks like that particular file is corrupt (however that might have happened). Please remove and try again.

comment:2 Changed 8 years ago by Don Quixote

bonefish, will do, but first I want to run checkfs on both my filesystems. They have been in use for quite a while.

I'm running an old nightly (hrev42778). I will also try with the latest nightly (hrev42884).

I have two filesystems. /boot is 2 GB, with 1.5 GB virtual memory. /Bild is where I do my Haiku builds. I was finding some bugs in Haiku by using it, so from time to time I test Haiku by thrashing on /Bild really hard, for example:

$ find /Bild -exec grep "Hello, World" {} \; -print

... at the top of the tree where I put both my sources and my build. This takes hours to run as it forks a grep process for each file and subdirectory. This hasn't been giving me trouble lately, but maybe there is filesystem corruption that checkfs doesn't find.

It's running under VirtualBox OSE, with both virtual drives being .vdi's attached via VirtualBox's SATA interface. Do we have any known problems with VirtualBox SATA?

comment:3 Changed 8 years ago by Don Quixote

Ah, I think /Bild, where I build Haiku, is corrupt. When I ran checkfs on it I got a bunch of messages that said various inodes couldn't be opened.

I'll save the .vdi in case anyone wants to look at it, then create a fresh filesystem to try my build on.

comment:4 Changed 8 years ago by bonefish

Resolution: invalid
Status: newclosed

OK, closing. Please reopen, if you can reproduce the issue with a clean FS.

Note: See TracTickets for help on using tickets.