Opened 8 years ago

Closed 8 years ago

#8039 closed bug (fixed)

Troubles reading ELF header in gcc4 opengl add-ons for any OpenGL program

Reported by: Don Quixote Owned by: anevilyak
Priority: low Milestone: R1
Component: Kits/OpenGL Kit Version: R1/Development
Keywords: OpenGL, gcc4, runtime_loader, GLTeapot, Haiku3D Cc:
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

When I launch the GLTeapot, Haiku 3D or the OpenGL Preferences app, I always get the following message on the serial debug shortly before the window opens:

runtime_loader: /boot/system/add-ons/opengl/gcc4: Troubles reading ELF header

The problem doesn't seem related to the load on the system.

This is under VirtualBox OSE on Ubuntu 11.04 on an Early 2006 MacBook Pro (Model Identifier MacBookPro1,1).

I've seen it happen with nightly builds hrev42778 and hrev42884.

I have saved a bunch of serial output log files, and will attach them if you like. But the bug is very easy for me to reproduce, so you should be able to see it in your own serial output.

My VirtualBox guests are using SATA virtual drives, not IDE. I'm hoping this makes them faster, but maybe it makes them buggier.

Change History (3)

comment:1 by anevilyak, 8 years ago

Component: Add-OnsKits/OpenGL Kit
Owner: changed from nobody to phoudoin
Priority: normallow
Status: newassigned

That error message is harmless, the problem is simply that the code which loads the list of OpenGL renderers isn't filtering out directories, and thus tries to load one as an add-on, which obviously won't work.

comment:2 by anevilyak, 8 years ago

Owner: changed from phoudoin to anevilyak
Status: assignedin-progress

comment:3 by anevilyak, 8 years ago

Resolution: fixed
Status: in-progressclosed

Fixed in hrev42890.

Note: See TracTickets for help on using tickets.