Opened 8 years ago

Closed 8 years ago

#8101 closed bug (fixed)

Vision hangs while connecting to freenode

Reported by: umccullough Owned by: anevilyak
Priority: normal Milestone: R1
Component: Applications Version: R1/Development
Keywords: Cc:
Blocked By: Blocking: #8121
Has a Patch: no Platform: All

Description

Just finished building an alpha gcc2hybrid on hrev43204.

Upon firing up Vision it hangs while connecting to freenode (I edited the settings before attempting to connect)

Screenshot attached - I haven't really dug into this much, but networking does work (I'm posting this ticket via Web+ on the very same build).

Anything I should change/try? I haven't messed with Haiku in a while, so I was surprised by this issue.

Attachments (1)

VisionHang.png (56.7 KB) - added by umccullough 8 years ago.
Screenshot of the hang

Download all attachments as: .zip

Change History (8)

Changed 8 years ago by umccullough

Attachment: VisionHang.png added

Screenshot of the hang

comment:1 Changed 8 years ago by anevilyak

Owner: changed from nobody to anevilyak
Status: newassigned

Something may have broken compat during the patches/code sprint week, I noticed a similar problem with Web+: try and open a link in a new tab, and it hangs too. Rebuilding Vision fixed it for me, it would be interesting to know if this affects R5 apps too or if it just affects things that are compiled natively, since that affects the behavior of the net stack.

comment:2 Changed 8 years ago by anevilyak

Come to think of it, could potentially also be due to the changes to the Notifications API, which I need to adjust Vision's usage of anyways.

comment:3 Changed 8 years ago by umccullough

hrev43152 works - I'll continue to bisect revs now

comment:4 Changed 8 years ago by anevilyak

Blocking: 8121 added

(In #8121) Same underlying issue as #8101.

comment:5 Changed 8 years ago by umccullough

Appears to be caused by hrev43166

comment:6 Changed 8 years ago by anevilyak

Indeed, thanks! Fixed in hrev43237.

comment:7 Changed 8 years ago by anevilyak

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.