Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#8122 closed bug (fixed)

Image creation problems in Ubuntu 11.10

Reported by: haiku_noob Owned by: bonefish
Priority: normal Milestone: R1
Component: Build System Version: R1/alpha3
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Using Ubuntu 11.10, I tried to build Haiku trunk with the following commands:

./configure --build-cross-tools ../buildtools/ ./configure --cross-tools-prefix cross-tools/bin/i586-pc-haiku- jam haiku-anyboot-image

After a while compilation finishes, but the build seems to be stuck at the message "Populating image...". I have left the computer working for awhile without success. Using top, I noticed that even while the hard disk is not working, the CPU usage rises up to 99% and remains there. The process using the CPU is bfs_shell. Tried the same process several times without positive results.

Change History (9)

comment:1 Changed 8 years ago by michaelvoliveira

Same here

but Cortex is not linking

comment:2 Changed 8 years ago by haiku_noob

I don't know how I even got it to compile... now I'm having problems with bison trying to build the buildtools... :(

comment:3 Changed 8 years ago by haiku_noob

Changed the bison version that comes with Ubuntu 11.10 by default to bison 2.0, at least it got further

comment:4 Changed 8 years ago by haiku_noob

Reinstalled everything, was using xubuntu based on ubuntu 11.10 (with btrfs), now using lubuntu (based on 11.10 too) with xfs. GCC 4 build is OK, however GCC 2.95 build is not (bison problems). I don't know what was the original problem, maybe it was something related to btrfs?. The GCC 2.95 problem is another issue (should I open another bug?)

comment:5 Changed 8 years ago by haiku_noob

FWIW Bison 1.28 from here http://ftp.gnu.org/gnu/bison/bison-1.28.tar.gz allows the building of the GCC 2.95 compiler. Maybe it should be included in the set of legacy tools together with the GCC sources...

comment:6 Changed 8 years ago by bonefish

Status: newin-progress

comment:7 Changed 8 years ago by bonefish

Resolution: fixed
Status: in-progressclosed

Should be fixed in hrev43273.

comment:8 Changed 8 years ago by bonefish

To clarify: The bison issue should be fixed (though I missed the files that actually were the problem -- corrected in hrev43274). Regarding the other problem, since you already reinstalled your build platform and can't reproduce the issue anymore, it's virtually impossible to do anything with the info you gave. In case you ran into it again, please create a new ticket. Also try to attach gdb to the bfs_shell process and get a back trace.

comment:9 Changed 8 years ago by haiku_noob

Thank you very much! Will see if the other problem reappears

Note: See TracTickets for help on using tickets.