Opened 8 years ago

Closed 8 years ago

Last modified 6 years ago

#8133 closed bug (duplicate)

Betrace crash at startup

Reported by: khallebal Owned by: korli
Priority: normal Milestone: R1
Component: Add-Ons/Translators/EXR Version: R1/Development
Keywords: Cc:
Blocked By: #1259 Blocking:
Has a Patch: no Platform: All

Description (last modified by anevilyak)

it may not be a haiku issue,so feel free to close the ticket as invalid if it's the case. rev: 43238 gcc2-hybrid here is the output:

 GNU gdb 6.3
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i586-pc-haiku"...(no debugging symbols found)

[tcsetpgrp failed in terminal_inferior: Invalid Argument]
Thread 1981 caused an exception: Segment violation
Reading symbols from /boot/system/runtime_loader...done.
Loaded symbols for /boot/system/runtime_loader
Reading symbols from /boot/system/lib/libbe.so...done.
Loaded symbols for /boot/system/lib/libbe.so
Reading symbols from /boot/system/lib/libroot.so...done.
Loaded symbols for /boot/system/lib/libroot.so
Reading symbols from /boot/system/lib/libtracker.so...done.
Loaded symbols for /boot/system/lib/libtracker.so
Reading symbols from /boot/system/lib/libtranslation.so...done.
Loaded symbols for /boot/system/lib/libtranslation.so
Reading symbols from /boot/system/lib/libnetwork.so...done.
Loaded symbols for /boot/system/lib/libnetwork.so
Reading symbols from /boot/system/lib/libstdc++.r4.so...done.
Loaded symbols for /boot/system/lib/libstdc++.r4.so
Reading symbols from /boot/system/lib/liblocale.so...done.
Loaded symbols for /boot/system/lib/liblocale.so
Reading symbols from /boot/system/lib/libtextencoding.so...done.
Loaded symbols for /boot/system/lib/libtextencoding.so
Reading symbols from /boot/system/lib/libicudata.so.48.1.1...done.
Loaded symbols for /boot/system/lib/libicudata.so.48.1.1
Reading symbols from /boot/system/lib/libicui18n.so.48.1.1...done.
Loaded symbols for /boot/system/lib/libicui18n.so.48.1.1
Reading symbols from /boot/system/lib/libicuio.so.48.1.1...done.
Loaded symbols for /boot/system/lib/libicuio.so.48.1.1
Reading symbols from /boot/system/lib/libicule.so.48.1.1...done.
Loaded symbols for /boot/system/lib/libicule.so.48.1.1
Reading symbols from /boot/system/lib/libiculx.so.48.1.1...done.
Loaded symbols for /boot/system/lib/libiculx.so.48.1.1
Reading symbols from /boot/system/lib/libicutu.so.48.1.1...done.
Loaded symbols for /boot/system/lib/libicutu.so.48.1.1
Reading symbols from /boot/system/lib/libicuuc.so.48.1.1...done.
Loaded symbols for /boot/system/lib/libicuuc.so.48.1.1
Reading symbols from /boot/system/lib/libroot-addon-icu.so...done.
Loaded symbols for /boot/system/lib/libroot-addon-icu.so
Reading symbols from /boot/system/add-ons/Translators/BMPTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/BMPTranslator
Reading symbols from /boot/system/add-ons/Translators/EXRTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/EXRTranslator
Reading symbols from /boot/system/lib/libilmimf.so...done.
Loaded symbols for /boot/system/lib/libilmimf.so
Reading symbols from /boot/system/lib/libz.so.1...done.
Loaded symbols for /boot/system/lib/libz.so.1
Reading symbols from /boot/system/add-ons/Translators/GIFTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/GIFTranslator
Reading symbols from /boot/system/add-ons/Translators/HVIFTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/HVIFTranslator
Reading symbols from /boot/system/add-ons/Translators/ICOTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/ICOTranslator
Reading symbols from /boot/system/add-ons/Translators/JPEG2000Translator...done.
Loaded symbols for /boot/system/add-ons/Translators/JPEG2000Translator
Reading symbols from /boot/system/add-ons/Translators/JPEGTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/JPEGTranslator
Reading symbols from /boot/system/lib/libjpeg.so.8.0...done.
Loaded symbols for /boot/system/lib/libjpeg.so.8.0
Reading symbols from /boot/system/add-ons/Translators/PCXTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/PCXTranslator
Reading symbols from /boot/system/add-ons/Translators/PNGTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/PNGTranslator
Reading symbols from /boot/system/lib/libpng.so.1.4...done.
Loaded symbols for /boot/system/lib/libpng.so.1.4
Reading symbols from /boot/system/add-ons/Translators/PPMTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/PPMTranslator
Reading symbols from /boot/system/add-ons/Translators/RAWTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/RAWTranslator
Reading symbols from /boot/system/add-ons/Translators/RTF-Translator...done.
Loaded symbols for /boot/system/add-ons/Translators/RTF-Translator
Reading symbols from /boot/system/add-ons/Translators/SGITranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/SGITranslator
Reading symbols from /boot/system/add-ons/Translators/STXTTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/STXTTranslator
Reading symbols from /boot/system/add-ons/Translators/TGATranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/TGATranslator
Reading symbols from /boot/system/add-ons/Translators/TIFFTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/TIFFTranslator
Reading symbols from /boot/system/lib/libtiff.so.3.8...done.
Loaded symbols for /boot/system/lib/libtiff.so.3.8
Reading symbols from /boot/system/add-ons/Translators/WebPTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/WebPTranslator
Reading symbols from /boot/system/add-ons/Translators/WonderBrushTranslator...done.
Loaded symbols for /boot/system/add-ons/Translators/WonderBrushTranslator
[tcsetpgrp failed in terminal_inferior: Invalid Argument]
[Switching to team /boot/home/config/add-ons/Tracker/BeTrace (1981) thread BeTrace (1981)]
0x004edc8c in __class_type_info::dcast () from /boot/system/lib/libroot.so
(gdb) bt
#0  0x004edc8c in __class_type_info::dcast () from /boot/system/lib/libroot.so
#1  0x004edc99 in __class_type_info::dcast () from /boot/system/lib/libroot.so
#2  0x004ee4ce in __throw_type_match_rtti () from /boot/system/lib/libroot.so
#3  0x004ebc69 in __cplus_type_matcher () from /boot/system/lib/libroot.so
#4  0x004ea47c in __eh_rtime_match () from /boot/system/lib/libroot.so
#5  0x01fb9557 in EXRTranslator::DerivedIdentify ()
   from /boot/system/add-ons/Translators/EXRTranslator
#6  0x01fbaded in BaseTranslator::BitsIdentify ()
   from /boot/system/add-ons/Translators/EXRTranslator
#7  0x01fbae5c in BaseTranslator::Identify ()
   from /boot/system/add-ons/Translators/EXRTranslator
#8  0x007d143e in BTranslatorRoster::Private::Identify ()
   from /boot/system/lib/libtranslation.so
#9  0x007d3f35 in BTranslatorRoster::Translate ()
   from /boot/system/lib/libtranslation.so
#10 0x007cd87c in BTranslationUtils::GetBitmap ()
   from /boot/system/lib/libtranslation.so
#11 0x007cd326 in BTranslationUtils::GetBitmap ()
   from /boot/system/lib/libtranslation.so
#12 0x002071ef in DrawPButton ()
#13 0x00207d00 in Window1::Window1 ()
#14 0x002070ce in Application1::ReadyToRun ()
#15 0x002dad01 in BApplication::DispatchMessage ()
   from /boot/system/lib/libbe.so
---Type <return> to continue, or q <return> to quit---
#16 0x002e5af9 in BLooper::task_looper () from /boot/system/lib/libbe.so
#17 0x002d994d in BApplication::Run () from /boot/system/lib/libbe.so
#18 0x00206ef4 in main ()
Current language:  auto; currently c++
(gdb) 

Change History (4)

comment:1 by anevilyak, 8 years ago

Component: - GeneralAdd-Ons/Translators/EXR
Description: modified (diff)
Owner: changed from nobody to korli

comment:2 by korli, 8 years ago

Blocked By: 1259 added
Resolution: duplicate
Status: newclosed

I suspect it's a duplicate of #1259

in reply to:  2 comment:3 by mmlr, 8 years ago

Replying to korli:

I suspect it's a duplicate of #1259

More directly a duplicate of #7785, but #1259 might be the root cause.

comment:4 by stippi, 6 years ago

While #1259 has not been fixed, yet, the symptoms observed in this bug have been fixed in hrev46924. (Note the link for the commit does not resolve to the actual commit which fixed it.)

Note: See TracTickets for help on using tickets.