Opened 8 years ago

Closed 6 years ago

#8136 closed bug (duplicate)

Audio becomes choppy and scratchy during normal operations.

Reported by: Giova84 Owned by: jua
Priority: normal Milestone: R1
Component: Drivers/Audio/auich Version: R1/Development
Keywords: audio choppy buffer frame size Cc:
Blocked By: #7882, #8007 Blocking:
Has a Patch: no Platform: All

Description

I have an ac97 soundcard recognized as Auich ICH. Due to this problem: (https://dev.haiku-os.org/ticket/8086) i set the auich.settings file with the right parameters. I set the buffer frames at 512, but is not enough: when i move windows, start apps, manage file and folders and browse on internet, audio of media files (played with MediaPlayer or with vlc) become choppy and scratchy, very unstable. I also tried to set the buffersize to 1024, but this doesn't solve.

R1A3 and hrev43238

Change History (9)

comment:1 Changed 8 years ago by ttcoder

Blocked By: 8007 added

You too have a single-CPU machine, probably?

If yes, then duplicate of #7882 in symptoms and #8007 for root cause..

Last edited 8 years ago by ttcoder (previous) (diff)

comment:2 Changed 8 years ago by Giova84

Yes, i have a single CPU machine. Is a Pentium 4 Willamette. But differently from #7882 in my case i get stuttering audio also when i open a folder, or if I move files, or if i start any app.. The situation is very bad!

comment:3 Changed 8 years ago by Giova84

And i get similar issues when i browse internet with WebPositive: while the pages are loading, Haiku freeze for a few seconds, until the pages are completely loaded!

comment:4 in reply to:  3 Changed 8 years ago by Giova84

Replying to Giova84:

And i get similar issues when i browse internet with WebPositive: while the pages are loading, Haiku freeze for a few seconds, until the pages are completely loaded!

Similar issue as #8007

comment:5 Changed 6 years ago by Giova84

hrev 46301 Despite the fact that this bug was solved https://dev.haiku-os.org/ticket/8007 I still have the issue, with the difference that, now, is less noticeable and annoying.

comment:6 Changed 6 years ago by diver

Component: - GeneralDrivers/Audio/auich
Owner: changed from nobody to jua
Status: newassigned
Version: R1/alpha3R1/Development

Maybe jua has an idea? ;-) Might be a Media Kit problem after all...

comment:7 Changed 6 years ago by Giova84

I have noticed that if i tuning the priorities (lower on WebPositive or to any running app) and higher on MediaPlayer and Media Servers, this issue become little noticeable, but still present.

comment:8 Changed 6 years ago by korli

Please note that nightlies have serial debugging activated by default. Please check in kernel settings.

comment:9 Changed 6 years ago by jua

Blocked By: 7882 added
Resolution: duplicate
Status: assignedclosed

Yes, serial debugging may be a problem, try to disable that (see my comment from today on #8007 how to do that).

Otherwise, this might be fixed by some upcoming MediaKit fixes which I will commit soon (next 1-2 weeks maybe).

Closing this ticket as duplicate of #7882, please continue discussion there :)

Note: See TracTickets for help on using tickets.