Opened 8 years ago

Closed 8 years ago

#8158 closed bug (duplicate)

Window z-level problems

Reported by: Duggan Owned by: axeld
Priority: normal Milestone: R1
Component: Servers/app_server Version: R1/alpha3
Keywords: Cc:
Blocked By: #7630 Blocking:
Has a Patch: no Platform: All

Description

Given there are 2 overlapping windows, A and B, A being the highest and currently selected, right click the tab of A sending it to the back. Notice A remains the currently selected window and subsequent mouse clicks will not bring it to the front without the user first deselecting it.

Change History (2)

comment:1 Changed 8 years ago by bonefish

I suppose that's in "Click to focus and raise" mode. One could also categorize the behavior as a feature. E.g. when you want to D&D something from large window to some small one that is obscured by the former, you can send it to back and start dragging without bringing it to front and obscuring the small window again.

BTW, you can still bring the window to front directly, similar to how you sent it to back in the first place, i.e. by clicking the tab or cmd-ctrl-clicking it.

comment:2 Changed 8 years ago by humdinger

Blocked By: 7630 added
Resolution: duplicate
Status: newclosed

This is a duplicate of #7630.
And it still annoys the heck out of me (that and Deskbar not coming to front when clicked. Drives me mad.). As written in #7630, Tracker windows behave as expected.

Note: See TracTickets for help on using tickets.