Opened 8 years ago

Closed 6 years ago

Last modified 17 months ago

#8157 closed bug (duplicate)

Parallels boot

Reported by: dcentity2000 Owned by: nobody
Priority: normal Milestone: R1
Component: Drivers/Disk Version: R1/alpha3
Keywords: Cc:
Blocked By: #4502 Blocking:
Has a Patch: no Platform: All

Description

Attempting to boot/install from the ISO provided on he downloads page fails in the Mac virtualisation software Parallels. However, the pre-prepared VMWare HDD image works in the Mac virtualisation software VMWare, meaning that it is not the hardware that is at fault. I have been playing about with fixed size drives, changing the number of processors and so on to no avail. To be precise, the boot screen shows and the first few icons light up, but the final two/three stay inert and Haiku fails to boot.

Attachments (2)

Screen Shot 2011-11-27 at 00.05.43.png (35.0 KB ) - added by dcentity2000 8 years ago.
haiku.txt (20.5 KB ) - added by oreru 8 years ago.
Full boot log until freeze

Download all attachments as: .zip

Change History (11)

comment:1 by Disreali, 8 years ago

This sounds like a it is Parallels bug and not Haiku. Does the ISO image work in VirtualBox on the Mac?

comment:2 by bonefish, 8 years ago

Component: Build System- General
Keywords: hang crash Parallels Mac virtualisation emulation removed
Owner: changed from bonefish to nobody
Status: newassigned

Please provide the serial debug output. I don't know Parallels, but I bet it supports adding a serial port and directing the output to a file or terminal.

by dcentity2000, 8 years ago

comment:3 by jonas.kirilla, 8 years ago

There is an early boot menu which provides among other things (safe mode options) the option to turn on textual output on screen. It can be entered by pressing and holding the shift key, as early as possible in the boot sequence. It's easy to miss. (You probably also need to turn off the paging of screen output, as your keyboard might not work yet at bootup. Mine does not.)

A cell phone photo of the textual boot screen where it gets stuck would help shine a light on where it gets stuck.

The option to turn on serial port output lives in the same menu, BTW, and I think it's off by default, so you may want to enter that menu anyway.

comment:4 by dcentity2000, 8 years ago

Holding down shift didn't do anything sadly.

It is also worth noting that Zeta 1.2 doesn't not boot either and hangs at the same point in booting. The only difference is that there is some text shown, sadly this is mostly hidden as the text is black on black.

comment:5 by Disreali, 8 years ago

Looks to be a duplicate of ticket:4561.

by oreru, 8 years ago

Attachment: haiku.txt added

Full boot log until freeze

comment:6 by diver, 7 years ago

Component: - GeneralDrivers/Disk

comment:7 by diver, 7 years ago

Blocking: 7665 added

comment:8 by diver, 6 years ago

Blocked By: 4502 added
Resolution: duplicate
Status: assignedclosed

comment:9 by waddlesplash, 17 months ago

Blocking: 7665 removed
Note: See TracTickets for help on using tickets.