Opened 8 years ago

Closed 8 years ago

#8167 closed bug (fixed)

/boot/home/config/be is missing breaking the Deskbar

Reported by: bbjimmy Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Deskbar Version: R1/Development
Keywords: Cc: zooey
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

hrev43324

The Deskbar menu folder had been moved to /boot/home/config/settings/deskbar, but there is no symlink to the folder named be in boot/home/config making all the BeOS, and some haiku, programs that place symlinks in the Deskbar menu break.

There is a symlink in /boot/home/config/settings named be that links to boot/home/config/settings/deskbar. This one should be removed as there is no need for it.

solution:

place a link to /boot/home/config/settings/deskbar in /boot/home/config and name it be

remove the be symlink in /boot/home/config/settings

Change History (4)

comment:1 by Disreali, 8 years ago

Component: - GeneralApplications/Deskbar
Owner: changed from nobody to axeld
Version: R1/alpha3R1/Development

Is this a situation in which adding a B_USER_DESKBAR_MENU_DIRECTORY entry to FindDirectory.h would be useful?

comment:2 by bbjimmy, 8 years ago

Most installers execute a shell script to place a symlink in the Deskbar menu. Beos used ~/config/be for the Deskbar menu. Haiku is now using ~/config/settings/deskbar for the Deskbar menu. I don't think that B_USER_DESKBAR_MENU_DIRECTORY will override a directory path placed in a shell script or compiled installer for a legacy (BoOS hrev5) program.

comment:3 by bonefish, 8 years ago

Cc: zooey added

Just rechecked the original changeset introducing the change and the symlink. I'd say it's just an oversight and the symlink was intended to live in ~/config directly.

in reply to:  2 comment:4 by zooey, 8 years ago

Resolution: fixed
Status: newclosed

Replying to bbjimmy:

Most installers execute a shell script to place a symlink in the Deskbar menu. Beos used ~/config/be for the Deskbar menu. Haiku is now using ~/config/settings/deskbar for the Deskbar menu. I don't think that B_USER_DESKBAR_MENU_DIRECTORY will override a directory path placed in a shell script or compiled installer for a legacy (BoOS hrev5) program.

If it doesn't, that's just an indication that the program should use find_directory (either the function or the cmdline utility). :-)

Anyway, since I'm sure many programs/installers have hardcoded the path, we do need the compatibility link in the right place.

Fixed in hrev43374.

Note: See TracTickets for help on using tickets.