Opened 8 years ago

Closed 8 years ago

#8168 closed bug (duplicate)

Error in AppFileInfo.cpp:183: `B_MIME_STRING_TYPE' undeclared (first use this function)

Reported by: scottmc Owned by: nobody
Priority: normal Milestone: R1
Component: Build System Version: R1/Development
Keywords: Cc:
Blocked By: #7824 Blocking:
Has a Patch: no Platform: All

Description

I got this warning when trying to jam haiku on haiku inside of VMware Workstation.

/Haiku8GB/haiku/haiku/src/build/libbe/storage/AppFileInfo.cpp: In method `status_t BAppFileInfo::GetType(char *) const':
/Haiku8GB/haiku/haiku/src/build/libbe/storage/AppFileInfo.cpp:183: `B_MIME_STRING_TYPE' undeclared (first use this function)
/Haiku8GB/haiku/haiku/src/build/libbe/storage/AppFileInfo.cpp:183: (Each undeclared identifier is reported only once
/Haiku8GB/haiku/haiku/src/build/libbe/storage/AppFileInfo.cpp:183: for each function it appears in.)

And got cc1plus: Invalid option `-Wno-invalid-offsetof'

MkDir1 generated/objects/haiku/x86/common/system 
...on 200th target...
MkDir1 generated/objects/haiku/x86/common/system/kernel 
MkDir1 generated/objects/haiku_host/x86/release/tools/gensyscalls 
C++ generated/objects/haiku_host/x86/release/tools/gensyscalls/gensyscalls.o 
MkDir1 generated/objects/haiku/x86/common/tools/gensyscalls 
C++ generated/objects/haiku_host/x86/release/tools/gensyscalls/gensyscallinfos.o 
Link generated/objects/haiku_host/x86/release/tools/gensyscalls/gensyscallinfos 
Chmod1 generated/objects/haiku_host/x86/release/tools/gensyscalls/gensyscallinfos 
PreprocessSyscalls generated/objects/haiku/x86/common/tools/gensyscalls/syscalls.h.pp.parsable 
GenSyscallInfos1 generated/objects/haiku/x86/common/tools/gensyscalls/gensyscalls_infos.cpp generated/objects/haiku/x86/common/tools/gensyscalls/syscall_types_sizes.h.cpp 
CreateAsmStructOffsetsHeader1 generated/objects/haiku/x86/common/tools/gensyscalls/syscall_types_sizes.h 
cc1plus: Invalid option `-Wno-invalid-offsetof'
C++ generated/objects/haiku_host/x86/release/tools/gensyscalls/gensyscalls_infos.o 

This was on hrev42747, clean git clone, with gcc-2.95.3-2011-11-22 installed from zip.

Change History (1)

comment:1 Changed 8 years ago by anevilyak

Blocked By: 7824 added
Component: - GeneralBuild System
Resolution: duplicate
Status: newclosed

Duplicate of #7824. For the time being, the 'fix' is to replace the host's storage/Mime.h and support/TypeConstants.h with those found in trunk since that constant was moved.

Edit: as for the invalid option, the toolchain has been updated since the rev you're running, which ties into the same issue of not being able to properly cross compile.

Last edited 8 years ago by anevilyak (previous) (diff)
Note: See TracTickets for help on using tickets.