Opened 8 years ago

Closed 8 years ago

#8186 closed bug (invalid)

Workspaces app does not Auto-raise

Reported by: devine Owned by: axeld
Priority: normal Milestone: R1
Component: Applications/Workspaces Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: yes Platform: All

Description

The Workspaces app Auto-raise was broken. When the mouse went to the edge of the screen it did not bring the Workspaces window the the front.

I've attached a patch to fix the problem.

Attachments (1)

WorkspacesRaise.diff (600 bytes ) - added by devine 8 years ago.
My first Haiku patch. Fixes the broken Auto-raise for Workspaces.

Download all attachments as: .zip

Change History (6)

by devine, 8 years ago

Attachment: WorkspacesRaise.diff added

My first Haiku patch. Fixes the broken Auto-raise for Workspaces.

comment:1 by devine, 8 years ago

Has a Patch: set

comment:2 by humdinger, 8 years ago

This can't be right. With this change applied, the Workspaces window would pop up every time your mouse gets near the screen edge. It should do that only if you're also over any part of the Workspaces window. Just like it's done with LaunchBox or the Deskbar with activated auto-raise.

comment:3 by devine, 8 years ago

That is the way the app was designed. To confirm this I noticed the command line switch that described the same behavior. However I do agree that the behavior should be the same as LaunchBox.

" --autoraise auto-raise the workspace window when it's at the screen edge."

I can lodge an enhancement ticket (which I am likely to try to solve myself).

Edit: I see that I was wrong, and have recieved feedback. A new patch should come soon.

Last edited 8 years ago by devine (previous) (diff)

comment:4 by devine, 8 years ago

It turns out the code is technically correct but the behavior needs turning so that it behaves as well as Launchbox does. I will lodge a separate enhancement ticket with patch.

comment:5 by anevilyak, 8 years ago

Resolution: invalid
Status: newclosed

Thanks for the update!

Note: See TracTickets for help on using tickets.