Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#8187 closed bug (fixed)

Transmission-daemon causes KDL when launched

Reported by: MichaelPeppers Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version: R1/Development
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

hrev43375, to reproduce just type "transmission-daemon" in a terminal window. The KDL is about some "_mutex_unlock() issues". It is quite a nasty one too as keyboard seems non-functional when it happens so the only thing I can do is a hard reboot. A clean syslog and (hopefully) a screenshot are coming soon.

Attachments (1)

haiku-r43413_transmission-daemon_kdl.jpg (162.2 KB) - added by Disreali 8 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 8 years ago by bonefish

Component: Applications/Command Line ToolsSystem/Kernel
Owner: changed from nobody to axeld

Changing component to kernel. Might be a network stack/driver issue, though. A stack trace would be very welcome.

comment:2 Changed 8 years ago by mmlr

Already fixed in hrev43405.

comment:3 Changed 8 years ago by mmlr

Resolution: fixed
Status: newclosed

comment:4 Changed 8 years ago by Disreali

Resolution: fixed
Status: closedreopened

Actually, invoking "transmission-daemon" still KDL's on hrev43414.

comment:5 Changed 8 years ago by MichaelPeppers

Cannot reproduce it in Virtualbox using hrev43413... will test it in real hardware ASAP.

comment:6 Changed 8 years ago by Disreali

Odd... I just got it to kdl on hrev43413 on Virtualbox as well as on real hardware. Once I exit the KDL, the system is unresponsive. I've even tried to do a 'on_exit kill <transmission id>' but the system still does not work.

Still getting the same KDL info as I did on hrev43372.

Changed 8 years ago by Disreali

comment:7 Changed 8 years ago by mmlr

Are you absolutely sure that this actually is hrev43413? It looks like exactly the bug I fixed in hrev43405 and I was unable to reproduce it in a downloaded nightly inside VirtualBox.

comment:8 Changed 8 years ago by bonefish

@mmlr: You had the right idea with hrev43405, but the line needs to be moved before the definition of the respective auto locker. Otherwise the reference is released before unlocking.

comment:9 in reply to:  7 Changed 8 years ago by Disreali

Replying to mmlr:

Are you absolutely sure that this actually is hrev43413? It looks like exactly the bug I fixed in hrev43405 and I was unable to reproduce it in a downloaded nightly inside VirtualBox.

Indeed it is. I did multiple fresh installs using both the iso and raw nightly images. transmission-daemon still KDL.

comment:10 Changed 8 years ago by Disreali

Invoking 'transmission-daemon' still causes KDL on hrev43436.

Last edited 8 years ago by Disreali (previous) (diff)

comment:11 Changed 8 years ago by mmlr

Resolution: fixed
Status: reopenedclosed

Fixed correctly in hrev43463.

comment:12 Changed 8 years ago by Disreali

Confirmed working on hrev43540. Thanks mmlr.

comment:13 Changed 8 years ago by Disreali

Commented to soon. Less than a few hours after I said the issue was fixed, transmission-daemon crashes my system. Will set up a vm to test.

Note: See TracTickets for help on using tickets.