Opened 13 years ago

Closed 10 years ago

#824 closed bug (fixed)

Booting from CD causes the floppy to constantly be polled

Reported by: johndrinkwater Owned by: axeld
Priority: normal Milestone: R1
Component: System/Kernel Version:
Keywords: Cc: adeynichenko@…
Blocked By: Blocking:
Has a Patch: no Platform: x86

Description

Steps to reproduce:

http://paginas.terra.com.br/informatica/pauloestrela/HaikuLiveCD.tar.bz2

Burn these two files to a CD (cdrecord dev=/dev/cdrom boot.image haiku.image). Insert Disc and reboot. While Haiku is loading, the floppy drive light will be on permenantly.

Expected: Floppy should be silently and unlit.

Might be a symptom from using his boot.image.

Change History (10)

comment:1 Changed 13 years ago by diver

Cc: diver added

comment:2 Changed 13 years ago by thorn

Cc: adeynichenko@… added; diver removed

comment:3 Changed 13 years ago by wkornewald

Milestone: R1

comment:4 Changed 12 years ago by axeld

Milestone: R1R1/alpha

comment:5 Changed 11 years ago by axeld

Can you enable the disabled code in line 68 in src/system/boot/platform/bios_ia32/shell.S to see if that helps you, and has no undesired effects like the broken reboot in Bochs? :-)

comment:6 Changed 11 years ago by aldeck

For what is worth, maybe i'm alone, but last time i was able to boot from cd was around summer 2006 iirc :) It stops there for me -> #1364

comment:7 in reply to:  6 Changed 11 years ago by jackburton

Replying to aldeck:

For what is worth, maybe i'm alone, but last time i was able to boot from cd was around summer 2006 iirc :) It stops there for me -> #1364

Booting from a cd now works, since hrev24224.

comment:8 Changed 11 years ago by axeld

Milestone: R1/alpha1R1

Not really an R1/alpha candidate, though.

comment:9 Changed 10 years ago by jonas.kirilla

The following was suggested on the haiku-development mailinglist as a fix to #824: http://www.freelists.org/post/haiku-development/xicon-and-executable-scripts,18

(Just recording this for posterity, in case the bug is still with us.)

comment:10 Changed 10 years ago by scottmc

Resolution: fixed
Status: newclosed

I've booted the Alpha ISO on a PC with a floppy drive and do not see this happening now. Closing. If it still happens for anyone we can always reopen this ticket.

Note: See TracTickets for help on using tickets.