Opened 8 years ago

Closed 3 months ago

#8267 closed bug (fixed)

Media Preferences shows orphaned MediaPlayer entries

Reported by: dsuden Owned by: nobody
Priority: normal Milestone: R1
Component: Kits/Media Kit Version: R1/alpha3
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description

Yesterday I had done a LOT of listening to songs by dragging songs into MediaPlayer (see seperate ticket on that) and occasionally MediaPlayer would fail, requiring that I kill and restart it. Later I looked in Media Preferences and there were a half dozen listings in there under Audio Mixer for "MediaPlayer audio out," so something wasn't getting cleaned up in there apparently.

I've seen the same thing occur with SoundPlay. If it gets killed and restarted, it leaves orphans behind in Media Preferences.

Change History (5)

comment:1 by diver, 5 years ago

Component: - GeneralKits/Media Kit
Owner: changed from nobody to axeld

Is this still reproducible?

comment:2 by dsuden, 5 years ago

Not really reproducible anymore, I don't think. Might be ready for retirement.

comment:3 by pulkomandy, 5 years ago

This still happens when an application crashes. It's rather easy to reproduce by crashing Web+ while playing a youtube video, for example.

comment:4 by axeld, 3 years ago

Owner: changed from axeld to nobody
Status: newassigned

comment:5 by leavengood, 3 months ago

Resolution: fixed
Status: assignedclosed

This should have been fixed by hrev53368. I don't think we show media apps in the Media Preferences anymore, but I opened Cortex and MediaPlayer disappeared even when I killed it from the terminal.

Note: See TracTickets for help on using tickets.