Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#831 closed bug (fixed)

email notification not send when new ticket created

Reported by: marcusoverhagen Owned by: wkornewald
Priority: critical Milestone: Website R1
Component: Website/Trac Version:
Keywords: Cc:
Blocked By: Blocking:
Has a Patch: no Platform: All

Description (last modified by axeld)

A email notification is not send to the assignee of a new created ticket. This should be fixed.

Change History (12)

comment:1 Changed 13 years ago by axeld

Priority: normalcritical

Looks like eMail notification does not work at all anymore! I closed ticket #830 and did not get any email about this (as I did before).

comment:2 Changed 13 years ago by wkornewald

Status: newassigned

I changed the email encoding from base64 to quoted-printable. That should fix the issue with SMTP servers bouncing base64-encoded messages. Does it work, now?

comment:3 Changed 13 years ago by wkornewald

Milestone: Website R1

Just to clarify (Axel mailed me): You only receive notifications when you are either the reporter, or you accepted the ticket, or your login name or email is in the "Cc" field. I disabled sending out messages to every commenter because it might disturb too many people. Or do you think that it's so extremely useful that those few who are disturbed can just delete those messages? There is probably not so much traffic, anyway.

comment:4 Changed 13 years ago by wkornewald

Well, I found the reason for those problems: site5 is limiting the number of concurrent SMTP connections. I contacted them, but it seems that they won't change anything. Always those stupid problems with our hosting...we will have to switch to some other service ASAP.

comment:5 Changed 13 years ago by wkornewald

Axel, could you please configure our bugs mailing list such that it doesn't block tickets which have lots of recipients?

I added an email accout for Trac and there have been no more SMTP errors (and thus missing notifications). We should test it some more, but I think it is fixed. Site5 might also have updated their email servers, so this could be the actual reason for the issue being fixed.

comment:6 Changed 13 years ago by axeld

I actually had a look at it, because one bounced, but I didn't find any option to do this.

comment:7 in reply to:  6 Changed 13 years ago by wkornewald

Replying to axeld:

I actually had a look at it, because one bounced, but I didn't find any option to do this.

I think the fix for the problem is explained here: http://www.uwex.edu/infosys/mailman/faqs/mailman.too.many.recipients.html

comment:8 Changed 13 years ago by axeld

Description: modified (diff)

Thanks! That did the trick! I've chosen 50 for now, but I can enlarge it as needed.

comment:9 Changed 13 years ago by wkornewald

Resolution: fixed
Status: assignedclosed

There have been enough ticket changes and not one single error. I'd say it's fixed.

comment:10 Changed 13 years ago by johndrinkwater

I'm subscribed to ticket #916, and didnt get one of b3w's update messages (comment 9).

comment:11 in reply to:  10 Changed 13 years ago by wkornewald

Replying to johndrinkwater:

I'm subscribed to ticket #916, and didnt get one of b3w's update messages (comment 9).

This email at least appears in the mailbox, so it must have been sent. What about the others subscribed to that ticket? Axel?

Also, why are the haiku-bugs list archives empty? I've subscribed Trac, now, but I thought it had already worked before. Strange...

comment:12 Changed 13 years ago by axeld

Just got another empty page when opening this bug, but I definitely got those messages. I'm afraid though, that I don't have them anymore, to check if the recipients are correct.

Note: See TracTickets for help on using tickets.